firefox won't open after linking jre-1.5.0_01/plugin/i586/ns7-gcc29/libjavaplugin_oji.so to firefox/plugins

RESOLVED INVALID

Status

Plugins Graveyard
Java (Sun)
--
minor
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: Charley Yeates, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

upgraded to firefox-1.0.1. Found JRE inoperable afterward. Found new version of
Java Runtime Environment (jre-1_5_0_01-linux-586-rpm.bin), installed same,
linked the plugin. firefox would not open after that. Broke the link, browser
works again.
 Dumped the download of JRE to eliminate corrupted copy. Same result. 
 Relinked the libjavaplugin_oji.so from the j2re-1.4.2_07 version, both work fine.
 Problem is replicable.
 I am not sure if this is a bug or just an incompatibility problem, and it is as
likely to be a Java problem as a Mozilla problem, I think.
 I could not find a place to report it to Java.com, but think the information 
ought to be available to others who might experience the problem. 

Reproducible: Always

Steps to Reproduce:
1. Upgrade to Firefox 1.01 installs in /usr/lib/firefox1.0.1 directory in FC3.
2. Download and standard install jre-1_5_0_01-linux-i586-rpm.bin
3. chmod jre, execute the .bin package, which self-extracts and installs to the
/usr/java directory in FC3. 
4. verify presence of 
/usr/java/jre1.5.0_01/plugin/i386/ns7-gcc21/libjavaplugin_oji.so.
5. cd /usr/lib/firefox-1.0.1/plugins
6. ln -s /usr/java/jre1.5.0_01/plugin/i386/ns7-gcc29/libjavaplugin_oji.so.
7. verify the link.
8. return to GUI and attempt to launch firefox, which failed to open - nothing,
in fact, happened.
**********this is all you have to do to replicate the problem.*****************
*******************************************************************************
9. checked all applicable directories and files. double checked that
/usr/lib/firefox was present in the env $PATH for both root and user accounts.

10. uninstalled, redownloaded and reinstalled the jre package, replicating steps
outlined above, and got the same results.
11. broke the plugin link from the jre1.5.0_01 install and reestablished the
ling to the j2re1.4.2_07 install, and everything is OK.
Actual Results:  
Browser failed to open. It tried - HDD LEd flickered.

Expected Results:  
It should have opened normally (and run all the stupid animated java applets
that get pushed on you from the web anymore).

Fairly standard if not state of the art box. Via 787CLR motherboard, 256Mb RAM,
Tualatin AMD Athlon at 1.8Ghz, FC3 workstation OS, 2.6.10-1.766_FC3 kernel,
768Kbs DSL ISP link.
 Fairly adept user, though not an expert by any means.
 As previously stated, I am not sure this is a bug; it is as likely to be and in-
compatibility issue, I think, and as likely (if not more so) to be a Java
problem as itis to be a Mozilla/firefox issue. 
  I am jus tof the opinion that the informatin ought ot be ab=vailable to an
entity  that can make it public knowledge with a work-around (go back to the
previous plugin).

Comment 1

13 years ago
Are you sure you linked to the right JRE plugin version? You need to use
i386/ns7/libjavaplugin_oji.so and not i386/ns7-gcc29/libjavaplugin_oji.so AFAIK
(except FC uses gcc 2.9 to compile Firefox which i doubt).

Comment 2

13 years ago
this is definitivly the wrong shared-library.
FC3's Firefox is compiled using gcc-3.4.

But why doesn't mozilla open at all, shouldn't it just ignore it and start withought the plugin?

lg Clemens

Comment 3

13 years ago
Firefox doesn't have a way to verify the ABI of a shared object on Linux.  (OK,
maybe through some major hacking it could, but I don't see us implementing
that.)  I'm going to therefore mark this bug as INVALID.

Also, reassigning to the proper component.
Assignee: bugs → nobody
Component: Software Update → Plug-ins
Product: Firefox → Core
QA Contact: bugs → plugins
Version: unspecified → Trunk

Comment 4

13 years ago
INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Plug-ins → Java (Sun)
Product: Core → Plugins
QA Contact: plugins → sun-java
Version: Trunk → unspecified
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.