Closing last tab with keyboard shortcut or script closes entire window.

VERIFIED DUPLICATE of bug 236721

Status

SeaMonkey
Tabbed Browser
--
minor
VERIFIED DUPLICATE of bug 236721
14 years ago
9 years ago

People

(Reporter: Daniel Cater, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050226 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050226 Firefox/1.0+

When the browser has only 1 tab left open, closing it using the keyboard
shortcut (Ctrl+W for me,) closes the entire window. Closing it using the close
tab widget at the far right of the tab bar, or by middle-clicking on the tab in
the tab-bar, does not close the entire window, but just blanks the last tab.
This is the desired result in my opinion.

This effect also occurs when using script. If you use script to open a new tab,
then close the opening tab, you will be left with the popup. If you then close
this popup with script

self.close();

this will also close down the entire window.

Reproducible: Always

Steps to Reproduce:
1. Have one tab open.
2. File -> Close Tab (Or perform the keyboard shortcut listed in that menu-item.
Actual Results:  
The entire window closes.

Expected Results:  
Blanked the last tab, as happens when using the middle-click function, or using
the close-tab widget in the tab-bar.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 236721 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
(Reporter)

Updated

9 years ago
QA Contact: tabbed-browser
You need to log in before you can comment on or make changes to this bug.