picture swap with onmouseover/onmouseout not stable

RESOLVED DUPLICATE of bug 283757

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 283757
13 years ago
13 years ago

People

(Reporter: Ruediger, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

At my page at http://toyah.willcox.de there is a table at the end ("Links to
Toyah in the web"), surrounded by two pictures.
When the mouse enters the middle table (the links), the left and right pictures
should change (onmouseover).
They do it, but when moving the mouse out of a link on to the next, it is
handled as a onmouseout (for a second), although all textlinks are within the
table. I´m not leaving the onmouseover area.
As s result the pictures flash.
Firefox has this misbehaviour as well as Netscape.
Opera and IE do not have this misbehaviour. They work well.

Reproducible: Always

Steps to Reproduce:
1. go to http://toyah.willcox.de
2. scroll down to "Links to Toyah in the web"
3. move the mouse over the links

Actual Results:  
moving the mouse from one textlink to another iniates a onmouseout, although I´m
not leaving the onmouseover-area (the middle table).
The picture flashes.

Expected Results:  
not initiating a onmouseout unless the mouse leaves the designated onmouseover area.

*** This bug has been marked as a duplicate of 283757 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
I don´t agree with you that it is a duplicate. My problem is new.
I found out that when a table or a table element (td, th, tr) is combined
with a mouseover, and this table-tag contains several elements
(here:textlinks), moving the mouse from one element to another initiates a
onmouseout with an immediately following onmouseover. But the onmouseover
area has never been left.

The case 283757 describes a problem with tooltips that don´t disappear. That
is a different problem

So I reopened the bug
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I am re-resoving this as a dupe.  Both issues have the same root cause.  I
cannot duplicate your issue with the patch that was checked in today to resolve
the other issue applied.  Please try tomorrows nightly build (which should
include the fix) and if you still see the issue, feel free to  re-open this bug.

*** This bug has been marked as a duplicate of 283757 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.