Build of 1.8b1 fails on solaris

VERIFIED FIXED

Status

()

Core
Printing: Output
--
blocker
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: Mats Larsson, Unassigned)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.5) Gecko/20041221 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.5) Gecko/20041221 Firefox/1.0

When building 1.8 beta 1 I get the following error:

gmake[5]: Leaving directory
`/opt/pub/src/mozilla/1.8b1/src/mozilla/gfx/src/psshared'
gmake[5]: Entering directory `/opt/pub/src/mozilla/1.8b1/src/mozilla/gfx/src/ps'
nsDeviceContextPS.cpp
Building deps for nsDeviceContextPS.cpp
CC -o nsDeviceContextPS.o -c  -DOSTYPE=\"SunOS5\" -DOSARCH=\"SunOS\"
-DHAVE_DEPENDENT_LIBS -I../.. -I./..  -I./../shared
-I../../../dist/include/xpcom -I../../../dist/include/string
-I../../../dist/include/widget -I../../../dist/include/pref
-I../../../dist/include/caps -I../../../dist/include/locale
-I../../../dist/include/uconv -I../../../dist/include/view
-I../../../dist/include/necko -I../../../dist/include/imglib2
-I../../../dist/include/unicharutil -I../../../dist/include/gfx
-I../../../dist/include
-I/opt/pub/src/mozilla/1.8b1/src/mozilla/dist/include/nspr     -I.
-I/opt/csw/include -I/opt/csw/include/freetype2   -I/usr/openwin/include   -KPIC
 -I/usr/openwin/include -xlibmil -xlibmopt -features=tmplife -norunpath
-xbuiltin=%all -mt -xbuiltin=%all -features=tmplife -mt  -DNDEBUG -DTRIMMED -xO3
-I/opt/csw/include/gtk-2.0 -I/opt/csw/lib/gtk-2.0/include
-I/opt/csw/include/atk-1.0 -I/opt/csw/include/pango-1.0 -I/opt/csw/include
-I/opt/csw/include/freetype2 -I/usr/openwin/include -I/opt/csw/include/glib-2.0
-I/opt/csw/lib/glib-2.0/include    -I/usr/openwin/include
-DMOZILLA_VERSION=\"1.8b\" -DSOLARIS=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1
-DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1
-DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1
-DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1
-DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1
-DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1
-DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -D_REENTRANT=1 -DHAVE_RANDOM=1
-DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1
-DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1
-DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1
-DHAVE_LANGINFO_CODESET=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1
-DHAVE_I18N_LC_MESSAGES=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk2\" -DMOZ_WIDGET_GTK2=1
-DMOZ_ENABLE_XREMOTE=1 -DMOZ_X11=1 -DMOZ_BUILD_APP=suite
-DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_ENABLE_XFT=1
-DMOZ_ENABLE_COREXFONTS=1 -DMOZ_ENABLE_GNOMEUI=1 -DMOZ_EXTRA_X11CONVERTERS=1
-DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1
-DMOZ_JSLOADER=1 -DMOZ_XTF=1 -DHAVE_GSSAPI_GSSAPI_H=1
-DHAVE_GSS_C_NT_HOSTBASED_SERVICE=1 -DMOZ_MATHML=1 -DMOZ_LOGGING=1
-DMOZ_USER_DIR=\".mozilla\" -DMOZ_XUL=1 -DMOZ_PROFILESHARING=1
-DMOZ_PROFILELOCKING=1 -DSUNCTL=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1
-DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1
-DMOZ_ACCESSIBILITY_ATK=1 -DMOZILLA_LOCALE_VERSION=\"1.8b\"
-DMOZILLA_REGION_VERSION=\"1.8b\" -DMOZILLA_SKIN_VERSION=\"1.5\" 
-D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT nsDeviceContextPS.cpp
"/usr/openwin/include/X11/Xutil.h", line 117: Error: Type name expected instead
of "Bool".
"/usr/openwin/include/X11/Xutil.h", line 120: Error: Type name expected instead
of "Pixmap".
"/usr/openwin/include/X11/Xutil.h", line 121: Error: Type name expected instead
of "Window".
"/usr/openwin/include/X11/Xutil.h", line 123: Error: Type name expected instead
of "Pixmap".
"/usr/openwin/include/X11/Xutil.h", line 124: Error: Type name expected instead
of "XID".
"/usr/openwin/include/X11/Xutil.h", line 161: Error: Type name expected instead
of "Atom".
"/usr/openwin/include/X11/Xutil.h", line 207: Error: Type name expected instead
of "XPointer".
"/usr/openwin/include/X11/Xutil.h", line 254: Error: Type name expected instead
of "Visual".
"/usr/openwin/include/X11/Xutil.h", line 255: Error: Type name expected instead
of "VisualID".
"/usr/openwin/include/X11/Xutil.h", line 287: Error: Type name expected instead
of "Colormap".
"/usr/openwin/include/X11/Xutil.h", line 295: Error: Type name expected instead
of "VisualID".
"/usr/openwin/include/X11/Xutil.h", line 296: Error: Type name expected instead
of "XID".
"/usr/openwin/include/X11/Xutil.h", line 365: Error: XRectangle is not defined.
"/usr/openwin/include/X11/Xutil.h", line 383: Error: Display is not defined.
"/usr/openwin/include/X11/Xutil.h", line 410: Error: Display is not defined.
"/usr/openwin/include/X11/Xutil.h", line 417: Error: Status is not defined.
"/usr/openwin/include/X11/Xutil.h", line 419: Error: Display is not defined.
"/usr/openwin/include/X11/Xutil.h", line 425: Error: Status is not defined.
"/usr/openwin/include/X11/Xutil.h", line 427: Error: Display is not defined.
"/usr/openwin/include/X11/Xutil.h", line 434: Error: Status is not defined.
"/usr/openwin/include/X11/Xutil.h", line 436: Error: Display is not defined.
"/usr/openwin/include/X11/Xutil.h", line 442: Error: Status is not defined.
"/usr/openwin/include/X11/Xutil.h", line 444: Error: Display is not defined.
"/usr/openwin/include/X11/Xutil.h", line 452: Error: Status is not defined.
"/usr/openwin/include/X11/Xutil.h", line 454: Error: Display is not defined.
Compilation aborted, too many Error messages.
gmake[5]: *** [nsDeviceContextPS.o] Error 1
gmake[5]: Leaving directory `/opt/pub/src/mozilla/1.8b1/src/mozilla/gfx/src/ps'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/opt/pub/src/mozilla/1.8b1/src/mozilla/gfx/src'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/opt/pub/src/mozilla/1.8b1/src/mozilla/gfx'
gmake[2]: *** [tier_9] Error 2
gmake[2]: Leaving directory `/opt/pub/src/mozilla/1.8b1/src/mozilla'
gmake[1]: *** [default] Error 2
gmake[1]: Leaving directory `/opt/pub/src/mozilla/1.8b1/src/mozilla'
gmake: *** [build] Error 2
gmake: *** No rule to make target `../../dist/bin/mozilla-bin', needed by
`mozilla-sparc-sun-solaris2.8-gtk2+xft.tar.bz2'.  Stop.

My build script which I used when building 1.7.5 without problems look like this:

cat << EOF > .mozconfig
ac_add_options --disable-debug
ac_add_options --disable-freetype2
ac_add_options --disable-tests
ac_add_options --enable-xft

ac_add_options --enable-application=suite
ac_add_options --enable-crypto
ac_add_options --enable-ctl
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-extensions=default,-irc
ac_add_options --enable-image-decoders=all
ac_add_options --enable-ldap-experimental
ac_add_options --enable-optimize="-xO3"
ac_add_options --enable-xinerama

ac_add_options --with-gtk-prefix=/opt/csw
ac_add_options --with-glib-prefix=/opt/csw

ac_add_options --x-includes=/usr/openwin/include
ac_add_options --x-libraries=/usr/openwin/lib

mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
EOF

export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
export NS_USE_NATIVE=1
export CC=cc
export CXX=CC
export CFLAGS="-xlibmil -xstrconst -xbuiltin=%all -mt"
export CXXFLAGS="-xlibmil -xlibmopt -features=tmplife -norunpath -xbuiltin=%all -mt"
#export LDFLAGS="-R/opt/csw/lib -R/usr/sfw/lib -R/opt/sfw/lib"
#export PATH=$PATH:/opt/sfw/bin:/usr/sfw/bin:/opt/pub/src/mozilla/bin
#export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/sfw/lib:/usr/sfw/lib:/opt/pub/src/mozilla/lib

gmake -f client.mk build
cd xpinstall/packager
gmake


Reproducible: Always

Steps to Reproduce:
See Details

Actual Results:  
Mozilla isn't built.

Expected Results:  
Built Mozilla.
Assignee: cmp → printing
Component: Build Config → Printing
Product: Mozilla Application Suite → Core
QA Contact: build-config
Summary: Build of 1.8b1 fails → Build of 1.8b1 fails on solaris
Version: unspecified → Trunk

Comment 1

14 years ago
This looks like bug 269601. If this is going to keep happening, we should 
probably work around it. 

Comment 2

13 years ago
Created attachment 183149 [details] [diff] [review]
small workaround patch

Although this bug is indeed a duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=269601 I've created a small patch
for myself, and it just might come in handy for others.

I'm not sure if this should be included in the source tree, but IMHO it helps
people on Solaris with this problem without affecting others, so maybe it
should be considered?

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
With this bug report, bug 269601 and my own build there are at least three cases
of this. In my case the environment is Solaris 9 with additional GTK2 installs.
(Reporter)

Comment 4

13 years ago
Patch in https://bugzilla.mozilla.org/show_bug.cgi?id=284077#c2 works for
Firefox/Thunderbird 1.1a1 as well.

Updated

13 years ago
Attachment #183149 - Flags: superreview?(roc)
Attachment #183149 - Flags: review+
Attachment #183149 - Flags: superreview?(roc) → superreview+

Updated

13 years ago
Attachment #183149 - Flags: approval1.8b3?

Updated

13 years ago
Attachment #183149 - Flags: approval1.8b3? → approval1.8b3+

Comment 5

13 years ago
Checked in. Thanks for the patch, Egon.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 6

13 years ago
Thanks for taking care of this Kenneth!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

13 years ago
Thanks for fixing this but I'm a little bit confused if it's fixed in 1.8b2 or
1.8b3?

Comment 8

13 years ago
Matt, Gecko 1.8b2 has already been released as part of firefox 1.1a1. The
mozilla foundation isn't releasing builds of the mozilla suite any more, so as I
understand it, numbers like 1.8b2 just refer to a revision of the gecko library
(including printing support) rather than a release of an application.
(Reporter)

Comment 9

13 years ago
OK, little less confused.

Comment 10

13 years ago
*** Bug 312400 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.