"Change Action" button highlighted when no actions shown, opens empty window

VERIFIED DUPLICATE of bug 300074

Status

()

Firefox
Preferences
VERIFIED DUPLICATE of bug 300074
13 years ago
11 years ago

People

(Reporter: PikeUK, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050228 Firefox/1.0+

Steps to Reproduce:
1. Goto Tools->Options->Downloads->View & Edit Actions.
2. Type a search that returns zero results, e.g. zzzzz.
3. Click the "Change Action" button.

Actual results
An empty window opens

Expected results
The Change Action button should have been disabled.

p.s. This also affects the "Remove Action" button and the "Remove Cookie" button
which are not disabled either (though they have no effect when clicked after a
empty search).

Comment 1

13 years ago
*** Bug 297617 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
This bug is still valid; however, you have to double-click on the associated
actions field after searching because the change action button remains disabled.
(Reporter)

Comment 3

12 years ago
Looks like someone fixed this in a newer bug, duping.

*** This bug has been marked as a duplicate of 300074 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.