"Remove Action" only available for types with an entry in mimetypes.rdf

RESOLVED INVALID

Status

()

Firefox
Preferences
--
trivial
RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: PikeUK, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
 
(Reporter)

Comment 1

13 years ago
Oops, again.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050228 Firefox/1.0+

The "Remove Action" button doesn't light up for types that don't have an entry
in mimetypes.rdf. This is noticable with types added by plugins.

Steps to Reproduce
1. Make sure you have the PDF plugin installed, you may need to start with a
clean mimetypes.rdf as well.
2. Goto Tools->Options->Downloads->View & Edit Actions.
3. Select a PDF type, notice the "Remove Action" button remains disabled.
4. Click "Change Action" and change to another action, e.g. "Open with default
application", and press OK.
5. Click "Change Action" again and change the type back to "Open in plug-in" and
press OK.
6. Close the Edit Actions dialog and reopen it.
7. Notice how "Remove Action" now lights up for the type you just altered,
whereas before it didn't.

Expected Behaviour
The "Remove Action" button should behave consistently for plugin types.
OS: other → Windows 98
*** Bug 289824 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
This is actually severely annoying. 
In a newly installed Deer Park, you can not remove any of the default types,
that it adds when creating a profile. You have to go thru that whole procedure
described by pike to have the Remove Action button enabled. no entries in
mimTypes.rdf for all of till that done either.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2) Gecko/20050531
Firefox/1.0+

Comment 4

13 years ago
(In reply to comment #3)
> In a newly installed Deer Park, you can not remove any of the default types,
> that it adds when creating a profile. You have to go thru that whole procedure
> described by pike to have the Remove Action button enabled. 

Not entirely -- you do have to change the action to something other than the 
plugin, but then you can Ok, select a different entry from the file-types list, 
re-select the original entry.  Remove is now enabled -- you don't have to change 
the action back to "Use plugin".

As reported, this bug isn't about enabling Remove for plugins, but about getting 
consistent behavior when a plugin entry is selected.
*** Bug 318542 has been marked as a duplicate of this bug. ***
*** Bug 327313 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences

Comment 8

12 years ago
Well even if this isn't exactly what I was looking for...it is a good starting point.
Assignee: bugs → nobody
(Reporter)

Comment 9

10 years ago
The "Remove Action" button is gone now that Download Actions has been replaced with "Applications", closing as INVALID.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 10

9 years ago
Should be RESOLVED DUPLICATE of bug 318279 (more or less).
You need to log in before you can comment on or make changes to this bug.