bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox refuses to play a QuickTime sound file which opens flawlessly on IE.

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Peter Kleer, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Every time I open this page (which has been programmed to automatically launch a
QuickTime sound file) -I'm getting the famous window bar "Additional plugins are
required to display all the media on this page." Then after clicking "Install
missing plugins..." and going through the entire process of manually installing
(re-installing in my case) the 'Apple Quicktime 6.5.1' -Firefox still refuses
play the file.

Reproducible: Always

Steps to Reproduce:
1.Go to page.
2.Top window bar appears asking to install QuickTime 6.5.1 plugin.
3.Click install.
4.Click next.
5.Click finish or even 'manual reinstall' & go through the entire process
-(including restarting the computer + coming back to the page)
Result = still nothing ...

Actual Results:  
Like QuickTime has never been installed.

Expected Results:  
Play the song the page has been programmed to play.
Do you see quicktime in "about:plugins" (use it as URl) to catch .wav ?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Do you see quicktime in "about:plugins" (use it as URl) to catch .wav ?

No. So I set QuickTime to play .wav & restart everything but with the same
result: "about:plugins" hasn't recorded the command that QuickTime has beem
asked to play .wav files from now on. (Actually, no other plugins seems to be
set to take up that task).
So I guess it's me (and not Firefox or chezmaya.com) because the page opens
flawlessly in IE.

Comment 3

14 years ago
I also get the same problem in different sites with a midi embedded. This seems
to happen when a player without a external plug-in such as winamp is the main
player, Firefox refuses recognize Quicktime has been installed, even though
quicktime is installed.

Thus, I think it would be best, if they made a plugin for decoding general sound
files, like .mp3, .mid, .wav, etc. along with some video files, and make firefox
do its own playback, instead of a 3rd party plug-in playback, which may not
integrate seemlessly.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> I also get the same problem in different sites with a midi embedded. 

I'm happy to announce that I've resolved my problem -thanks to Matthias Versen.
The problem came from QuickTime not being set to play .wav found in a browser page.
And now here's the recipe: 
Go to QuickTime Player: Edit / Preferences / QuickTime Preferences / Browser Plug-in
There - click the [MIME Settings...] box
      - expend 'Audio - Audio only file formats'
      - check the 'WAVE audio file' box
      - click [OK] 
You're done! Embedded .WAVs should start playing automatically.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 5

14 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > I also get the same problem in different sites with a midi embedded. 
> 
> I'm happy to announce that I've resolved my problem -thanks to Matthias Versen.
> The problem came from QuickTime not being set to play .wav found in a browser
page.
> And now here's the recipe: 
> Go to QuickTime Player: Edit / Preferences / QuickTime Preferences / Browser
Plug-in
> There - click the [MIME Settings...] box
>       - expend 'Audio - Audio only file formats'
>       - check the 'WAVE audio file' box
>       - click [OK] 
> You're done! Embedded .WAVs should start playing automatically.
> 


You see the problem is that not all people want QuickTime to the default wave
form player. I still want Winamp to play wave files when I double click on the
wave files. Thus I think it would necessary for a plugin or adpator be developed
that forces firefox to recognize quicktime is installed without having to set
MIME settings for wave to be defaulted to quicktime. (Same with midi files)
You need to log in before you can comment on or make changes to this bug.