z-index problem when using HTML lists for pulldown menus

RESOLVED FIXED

Status

()

defect
--
major
RESOLVED FIXED
14 years ago
9 months ago

People

(Reporter: johannes.langlotz, Assigned: roc)

Tracking

({testcase})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

The pulldown menu at http://www.webminster.de/extern/mozilla/bug-z-index/ should
be above the rest of the page. If a pulldown menu is above a input form the text
of the form (only the text!) is displayed above the pulldown menu.

Reproducible: Always

Steps to Reproduce:
1. goto http://www.webminster.de/extern/mozilla/bug-z-index/
2. move your mouse over the "About Blender" button
3. the text of the input form below the pulldown menu is rendered above the
pulldown menu

Actual Results:  
the text of the input form below the pulldown menu is rendered above the
pulldown menu

Expected Results:  
the text of the input form below the pulldown menu should be rendered below the
pulldown menu
Reporter

Comment 1

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1
> 
> The pulldown menu at http://www.webminster.de/extern/mozilla/bug-z-index/ should
> be above the rest of the page. If a pulldown menu is above a input form the text
> of the form (only the text!) is displayed above the pulldown menu.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. goto http://www.webminster.de/extern/mozilla/bug-z-index/
> 2. move your mouse over the "About Blender" button
> 3. the text of the input form below the pulldown menu is rendered above the
> pulldown menu
> 
> Actual Results:  
> the text of the input form below the pulldown menu is rendered above the
> pulldown menu
> 
> Expected Results:  
> the text of the input form below the pulldown menu should be rendered below the
> pulldown menu. if you increase the font size with CRTL + + and decrease it
with CTRL + - it renders correct

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1
> 
> The pulldown menu at http://www.webminster.de/extern/mozilla/bug-z-index/ should
> be above the rest of the page. If a pulldown menu is above a input form the text
> of the form (only the text!) is displayed above the pulldown menu.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. goto http://www.webminster.de/extern/mozilla/bug-z-index/
> 2. move your mouse over the "About Blender" button
> 3. the text of the input form below the pulldown menu is rendered above the
> pulldown menu
> 
> Actual Results:  
> the text of the input form below the pulldown menu is rendered above the
> pulldown menu
> 
> Expected Results:  
> the text of the input form below the pulldown menu should be rendered below the
> pulldown menu

Reporter

Comment 2

14 years ago
if you increase the font size with CRTL + + and decrease it
with CTRL + - it renders correct
Confirming.  Note that the absolute position and hidden overflow are needed
here.  It looks to me like some code gets confused about the z-ordering because
of the "we clip things, but not absolutely positioned things" stuff that
scrollframes do.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 5

14 years ago
Here is a second example where foxfire does not handle the z-index of list
elements correctly. It does not mater if I give a z-index or not the address
text for the base menu items shows through absolutely positioned elements that
belong to lists above them. I tried reversing the z-indexs in the list, but it
did not make any difference.

Comment 6

14 years ago
Comment on attachment 181879 [details]
Link text in list menu shows through active menu 

This problem showed up on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7.7) Gecko/20050414 Firefox/1.0.3
I think this is WFM in my debug build that has the "frame display lists" patch
in it (bug 317375).
Depends on: 317375
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012614

WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.