Page doesn't display correctly

VERIFIED DUPLICATE of bug 29749

Status

()

Core
Layout: HTML Frames
P3
normal
VERIFIED DUPLICATE of bug 29749
18 years ago
18 years ago

People

(Reporter: Andreas Weder, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The frame border between the menu frame on the left and the content frame on the 
right is approx. 100 pixels wide. It's painted in white (Netscape 4.7 shows no 
border at all, just a scrollbar for the menu frame).

Build ID: 2000021808

Comment 1

18 years ago
troy/Layout -> karnaze/HTMLFrames (although maybe the HTMLFrames code should 
never see the bogus keyword for 'border'; parser ??)

Given the HTML below ...

   <frameset border="false" cols="139,*">
     <frame src="http://www.mozilla.org/">
     <frame src="http://www.mozilla.org/">
   </frameset>

... it appears that for attribute 'border="false"', "false" is
converted to an int for pixel width of the border. The result is a
very wide border on the frameset.

By the way, that keyword is not supported by IE either, but both IE
and Nav4.x toss out the bogus value.
http://msdn.microsoft.com/workshop/author/dhtml/reference/properties/border_1.a
sp
(Curiously, though, the original URL is generated by Frontpage 4.0. Go figure).
Assignee: troy → karnaze
Status: UNCONFIRMED → NEW
Component: Layout → HTMLFrames
Ever confirmed: true

Comment 2

18 years ago
Reassigning to Eric.
Assignee: karnaze → pollmann
(Assignee)

Comment 3

18 years ago
Dup of bug 29749.  I'll nominate this for beta1 - too many dups to ignore this
recent regression.

*** This bug has been marked as a duplicate of 29749 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Marking verified dup of 29749.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.