Status

SeaMonkey
Build Config
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Ginn Chen, Assigned: Chase Phillips)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

840 bytes, patch
Brian Ryner (not reading)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
Mozilla build failed.

CC -o mozilla-installer-bin -I/usr/openwin/include -xbuiltin=%all
-features=tmplife -mt  -DDEBUG -D_DEBUG -DDEBUG_ginn -DTRACING -g -xO4
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include
-I/usr/sfw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
   nsINIParser.o nsXInstallerDlg.o nsComponent.o nsSetupType.o nsComponentList.o
nsObjectIgnore.o nsLegacyCheck.o nsRunApp.o nsLicenseDlg.o nsWelcomeDlg.o
nsSetupTypeDlg.o nsComponentsDlg.o nsInstallDlg.o nsZipExtractor.o nsXIOptions.o
nsXIContext.o nsXInstaller.o nsXIEngine.o   -xildoff -zlazyload -zcombreloc    
      -L../../../../dist/bin -L../../../../dist/lib -lgtk-x11-2.0 -lgdk-x11-2.0
-latk-1.0 -lgdk_pixbuf-2.0 -lm -lmlib -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
-lgobject-2.0 -lgmodule-2.0 -lglib-2.0   ../../../../dist/lib/libjar50_s.a
../../../../dist/lib/libxpnet_s.a -lpthread  -lsocket -ldl -lm
Undefined                       first referenced
 symbol                             in file
gethostbyaddr                      
../../../../dist/lib/libxpnet_s.a(nsSocket.o)  (symbol belongs to implicit
dependency /usr/lib/libnsl.so.1)
gethostbyname                      
../../../../dist/lib/libxpnet_s.a(nsSocket.o)  (symbol belongs to implicit
dependency /usr/lib/libnsl.so.1)
inet_addr                          
../../../../dist/lib/libxpnet_s.a(nsSocket.o)  (symbol belongs to implicit
dependency /usr/lib/libnsl.so.1)
ld: fatal: Symbol referencing errors. No output written to
mozilla-installer-bingmake[1]: *** [mozilla-installer-bin] Error 1
(Reporter)

Comment 1

13 years ago
caused by checkin of bug 183389
(Reporter)

Comment 2

13 years ago
Created attachment 175919 [details] [diff] [review]
patch

patch as same as bug 260337
Attachment #175919 - Flags: review?(bryner)

Comment 3

13 years ago
*** Bug 284406 has been marked as a duplicate of this bug. ***
Attachment #175919 - Flags: review?(bryner) → review+
(Reporter)

Updated

13 years ago
Attachment #175919 - Flags: superreview?(Henry.Jia)

Comment 4

13 years ago
Ginn: 1 review is sufficient for build config.  See:
http://www.mozilla.org/hacking/reviewers.html
(Reporter)

Updated

13 years ago
Attachment #175919 - Flags: superreview?(Henry.Jia)
(Reporter)

Comment 5

13 years ago
Checking in Makefile.in;
/cvsroot/mozilla/xpinstall/wizard/unix/src2/Makefile.in,v  <--  Makefile.in
new revision: 1.29; previous revision: 1.28
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.