Tabs loading in background forced to foreground

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: David Hagood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041121 MultiZilla/1.8.0.0a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041121 MultiZilla/1.8.0.0a

Tabs that are loading in the background are forced to foreground.

This only started when I switched Multizilla's Javascript blocker from "Block
all" to "Ask".


Reproducible: Always

Steps to Reproduce:
1) Install Multizilla, configure Javascript permissions to "ask".
2) Open a page with links to pages on other servers that use Javascript: for
example, open news.google.com, and locate a link on www.cnn.com.
3) Load a link to another site which uses Javascript in the background.
4) When Multizilla brings that tab to the foreground and asks "Allow (site) to
load Javascript" - indicate NO and "Remember this". Repeat as needed until the
site loads.
5) Close the newly-opened tab and return to the first tab (google).
6) Once again, load the link to the second site in the background.

Actual Results:  
Site will start to load in the background, then be forced to the foreground.


Expected Results:  

Site will now load in the background (unless a new ad site is inserted requiring
a new Javascript prompt).


I conjecture that the Javascript blocking code is forcing the tab to the
foreground because it "might" need to generate a dialog, rather than waiting
until a dialog is actually needed.
(Reporter)

Comment 1

13 years ago
Additional data: this behavior ceases (Mozilla operates as expected) if the JS
pref is changed from "Ask" to "Block".

Comment 2

13 years ago
The regulars at b.m.o. will not normally accept problems relating to
extensions.

Comment 3

13 years ago
this should be filed in http://bugzilla.mozdev.org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.