Closed Bug 284314 Opened 19 years ago Closed 19 years ago

disable cancel or window killing when we're past the point of no return in the installer

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 260700

People

(Reporter: asa, Assigned: bugs)

Details

Currently the user can bail on an install after we've started to overwrite files
from her previous release and she'll end up with a busted installation. We
should block the cancel or window close when we're as far as that state where
the user's installation is going to be hosed. 

Also, if we can install to temp and then copy over the old installation, we
might reduce the window of time where we're in that no-return state.
Flags: blocking-aviary1.1+
Suggest to code installer to backup old files during installation so that
software can be reverted in case of any installation errors while running Setup.
I've had users hit cancel durring the upgrade process, then they could not use
firefox.  I agree the cancel and close buttons should be disabled durring this
period of being "Past the point of no return".  This showed up running the 1.0.2
upgrade.

I think the severity of this bug should be moved higher because the end user
suddenly is left without access to the default web browser.

While the fix seems to be, re-running the installation program over again (it's
left on the desktop).

I've also seen this bug on Windows NT and think it would appear on every windows
version.
Whiteboard: [asaP1]

*** This bug has been marked as a duplicate of 260700 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Flags: blocking-aviary1.1+
Whiteboard: [asaP1]
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.