[RFE] Anonymous browsing mode

RESOLVED DUPLICATE of bug 172993

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 172993
14 years ago
5 years ago

People

(Reporter: Vladislav Duma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; ru-RU; rv:1.5) Gecko/20031006
Build Identifier: Mozilla/5.0 (Windows; U; Win98; ru-RU; rv:1.5) Gecko/20031006

The Netscape Browser, released at the end of Nov 2004, there's a button
"Anonymous mode" (see
http://wangrepublic.org/daniel/netscape_browser_prototype/Netscape_Browser_prototype_%20w_sidebar_&_anonymous_mode_screenshot).
Perhaps it's possible to implement such a feature in Mozilla as well?

According to http://mozillanews.org/?article_date=2004-11-30+19-06-12, the
functionality in Netscape prototype is to clean histories on exit. The better
solution would be perhaps just not to store the history information till exit
from the anonymous mode, so the old histoty won't be affected.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
This feature will be in the next release of firefox, Firefox 1.1. Not really a
bug to point you to since it's included with the new options dialog. The feautre
right now is called 'Sanitize Settings' and you can select to clean up your
tracks when you exit firefox.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> This feature will be in the next release of firefox, Firefox 1.1. Not really a
> bug to point you to since it's included with the new options dialog. The feautre
> right now is called 'Sanitize Settings' and you can select to clean up your
> tracks when you exit firefox.

Well, this sounds good. But:
(1) I would like the browser to keep the history of non-anonymous browsing. I am
not sure whether this will be the case.
(2) What about Seamonkey? The bug (or better RFE) is filed against Mozilla Suite...

Comment 3

14 years ago
sorry for the bugspam, missed reading this was filed for Mozilla Suite

Comment 4

14 years ago
I believe bug 172993 - Temporarily disable history - fits exactly what you write
here: "not to store the history information till exit from the anonymous mode,
so the old histoty won't be affected."

Mind you that apps like Norton Internet Security can be configured to log all
visited URLs.

Related:
Bug 196925, bug 45734, bug 202910

*** This bug has been marked as a duplicate of 172993 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> I believe bug 172993 - Temporarily disable history - fits exactly what you write
> here: "not to store the history information till exit from the anonymous mode,
> so the old histoty won't be affected."

Well, I would say -- fits only partially. At the screenshot (see description)
the notion "history" is likely to consist of (1) page history, (2) download
history, (3) search history, (4) cookies, (5) cache; I would add here perhaps
location bar history + autocomplete (from bug 196925).

> Mind you that apps like Norton Internet Security can be configured to log all
> visited URLs.
Yes, definitely, but this is not a Mozilla issue ;-)

> *** This bug has been marked as a duplicate of 172993 ***
Maybe not a duplicate? This RFE is somewhat broader. Or should it be split into
several RFEs?

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.