Closed Bug 284359 Opened 15 years ago Closed 11 years ago

Animated Preferences dialog flashes black on Windows (animateFadeIn)

Categories

(Firefox :: Preferences, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ttolonen, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050301 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050301 Firefox/1.0+

Enabling browser.preferences.animateFadeIn setting on windows causes some tabs
to flash black in the preferences dialog.

When switching between General, Privacy and Downloads tabs a black block flashes
on the preferences dialog.

Switching between Content, Tabs and Advanced tabs works as expected and the fade
effect is smooth

Reproducible: Always

Steps to Reproduce:
Works for me, same setup and build. Graphic card:9800pro Drivers:Catalysts 4.11
I'm getting the same behavior. My video card's an ATi 9700 Mobility w/128MB of RAM.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050301
Firefox/1.0+

black flash

Matrox G200 card

->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
weird I didn't see it at all last night but today I see it with same build
Flags: blocking-aviary1.1?
not a blocker.  Unless this is present on a platform that actually uses/exposes
this feature, its fine to ship with.

If it worked fine, I'm sure it would have been enabled on Windows.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Summary: Animated Preferences dialog flashes black → Animated Preferences dialog flashes black on Windows
Probably far fetched since I really don't understand coding but can the fade
effect for menu and tooltips not be used on XP? Control
Panel->Display->Appearance->Effects->'Use the following transition effect for
menus and tooltips:' (fade effect)
I know this only applies on the start menu but could you guys get it working for
the options dialog? or is this completly a windows limitation?
The MSDN docs for the fade effect (here:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/winui/winui/windowsuserinterface/windowing/windows/windowreference/windowfunctions/animatewindow.asp
) indicate that the window must be a top-level window for the AW_BLEND keyword
to work. It seems to me that the entire window would have to be faded back in
every time we changed tabs for the fade effect to work properly.

I'm not too familiar with XUL myself, but I don't see how we could call a
Windows API function from the code for the Prefwindow. It seems like we'd have
to write something into the XUL framework that handles window animations for the
whole toolkit. The expose that method to the XUL code. This could be useful if
we plan on making any of the rest of the windows use the fade effect. But it
would also require variations on the code for the different platforms that
support Window animations. Can anybody more familiar with the XUL framework tell
me if this is correct?
Can we at least remove this then until a patch comes along? If its not working
properly on windows why release firefox knowingly it not fixeable anytime soon
when its not feature that anybody needs. There will be many bug reports filed
over this becuase its noticeable to everyone on windows.

I know it's not like its a major bug or anything but still its ugly.
please ignore last comment...slipped my mind that this is turned on via
about:config and not in the options panel.
Summary: Animated Preferences dialog flashes black on Windows → Animated Preferences dialog flashes black on Windows (animateFadeIn)
I noticed this problem too... if someone could create a reduced testcase we
could show to roc, that'd be super helpful. 
Severity: trivial → normal
Its trivial, its an intermittent visual glitch that has no effect on
functionality .  On a platform where its not even enabled by default.
Severity: normal → trivial
I don't know if that can help, but on Windows 2000/XP I see the same problem for
all applications that use transparency. As soon as we set the transparency from
0% to 1% or more, we see a flash black. After, if we change the transparency
value from 1% to 30% for instance, we don't see a flash.

You can try to make any window transparent with this freeware :
http://www.gibinsoft.net/gipoutils/deskutil/index.htm
I tried with Notepad, and I always see the problem.

Maybe it's a Windows problem?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050407
Firefox/1.0+

WFM (I have no idea since when and what fixed it though)
WFM as well, same build as comment 13, on windows xp
WFM too.

Must have been fixed somewhere between 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050330
Firefox/1.0+
and
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050407
Firefox/1.0+

but with which change exactly?

btw: Maybe browser.preferences.animateFadeIn could be enabled by default now?
> Maybe browser.preferences.animateFadeIn could be enabled by default now?

Not until bug 284414 is fixed.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
Assignee: bugs → nobody
See several WFM's in the comments.
WFM for me also in all current FF builds (2-3.6nightlies).
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.