linux: not prompted to enter master passwd for new profile

VERIFIED WORKSFORME

Status

SeaMonkey
Passwords & Permissions
P3
blocker
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Stephen P. Morse)

Tracking

({pp, regression})

Trunk
Other
Linux
pp, regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] can't reproduce, URL)

(Reporter)

Description

19 years ago
found using the 2000021808 opt comm bits; *not* a problem on winNT or mac.

recipe:
1. create a new profile and start seamonkey with it.
2. go to the above url; fill in the username/passwd fields. observe: i wasn't
able to type anything in the passwd field, oddly enough (no asterisks echoed
back) --indicative of another [new] bug?
3. click login. when the Confirm dialogs asks whether you want to save the
username/passwd info, click Yes.

expected: should get the Password dialog, which initially displays the
encryption disclaimer (bug 27725), along with the usual two input fields.

result: no Password dialog appears at all.
(Reporter)

Updated

19 years ago
Keywords: beta1, pp, regression
(Reporter)

Updated

19 years ago
Blocks: 27725
(Assignee)

Comment 1

19 years ago
The inability to type anything into the password field is bug report 24318.  
(Assignee)

Comment 2

19 years ago
Strange, this is all working fine for me with a tree that I just pulled and 
built this morning.  On linux of course.  Even the typing-in-password-field 
problem did not occur.
(Assignee)

Comment 3

19 years ago
OK, you are using the commercial build and I am using the mozilla build.  That 
must be the difference.

Comment 4

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 5

19 years ago
Sarah, are you still seeing this?  I am unable to reproduce.
(Reporter)

Comment 6

19 years ago
this is still a problem for me when i created/used a new profile with today's
opt comm bits on linux [2000022108].
(Assignee)

Comment 7

19 years ago
See bug 28442 about possible errors in the packager manifests.  That may be the 
cause of this bug as well.  I suspect that because, like that other bug, this 
one works fine for me when I build the product but does not work for q/a when 
they test it with the installed bits.
Depends on: 28442

Comment 8

19 years ago
per PDT, Steve, can you verify that the packager manifest is correct? Need an
ETA on a fix for this.
(Assignee)

Comment 9

19 years ago
The package manifest is indeed not correct.  Could very well be the cause of 
this bug as well as bug 28442.  But we won't know that until this is checked in 
and new installer bits are pulled the next day.

Checkin is ready to go -- awaiting code review (jband) and approval (jevering).
Whiteboard: [PDT+] → [PDT+] fix in hand, awaiting approvals

Comment 10

19 years ago
I can help review your packager list change if you need.
(Assignee)

Comment 11

19 years ago
Cathleen, thanks for the offer.  The proposed changes (and rationale for 
them) are specified in bug 28442.  I'm awaiting a code review from jband but if 
you can code review it before he does, I can check it in that much quicker.

Comment 12

19 years ago
no problem!  Are you in?  If not, send me your diff!  :-)

Comment 13

19 years ago
What you propose to do sounds fine. But, I don't see the specific changes you 
propose to commit to the repository. Cathleen is a much better reviewer since 
she's probably setup to actually test the changes and I know she knowns a 
lot more about this installer stuff then I.
(Assignee)

Comment 14

19 years ago
Updated packages-* files checked in.  That should fix this problem.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] fix in hand, awaiting approvals → [PDT+]
(Reporter)

Comment 15

19 years ago
still reproducible using linux opt comm bits 2000022409.

marking this as blocker, too, since w/o a master passwd i'm unable to Display
Signons w/a new profile (either from Tasks > Autofill > Display Signons menu
item, or from Advanced > Master Password pref).
Severity: critical → blocker
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Whiteboard: [PDT+] → [PDT+] can't reproduce
(Assignee)

Comment 16

19 years ago
Still cannot reproduce.  Just spoke to sairuh and now she can't reproduce it 
either.  So I'm closing this out as works-for-me.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

19 years ago
yah, wfm using today's opt comm bits 2000022509.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.