focus lost after closing history and switching tabs

VERIFIED DUPLICATE of bug 254056

Status

()

VERIFIED DUPLICATE of bug 254056
14 years ago
14 years ago

People

(Reporter: bryner, Assigned: bryner)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

14 years ago
Seen with current Firefox trunk builds on winxp:

1. Start Firefox
2. Ctrl+H to open history sidebar
3. Click on a history link, this will load it into the main content area
4. Middle-click a second history link, this will load it in a new tab
5. Ctrl+H to close history sidebar
6. Verify that you can use pgup/pgdn/tab to navigate the last-opened page
7. Ctrl+pgup to switch back to the first tab.
8. Press pgup, pgdown, tab, etc

Result: focus is either dead, or you're navigating the background page

Expected result: navigating the foregroup page
(Assignee)

Comment 1

14 years ago
would be nice to fix this polish issue for 1.1
Flags: blocking-aviary1.1?
this sounds quite similar to bug 242820 --would these have the same root problem?
(Assignee)

Comment 4

14 years ago
One day I'll be organized.

*** This bug has been marked as a duplicate of 254056 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

14 years ago
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.