XML prettyprint is not working

RESOLVED FIXED

Status

()

Firefox
File Handling
--
major
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Mats Åhlberg, Assigned: gandalf)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050228 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050228 Firefox/1.0+

I have a page that loads xml and displays it.
Now the windows is empty but the source shows valid xml.
and some pages show xml without the tags.

Reproducible: Always

Steps to Reproduce:
1.Load xml-document

Actual Results:  
Empty window.

Expected Results:  
Xml prettyprint should have been anabled to show me xml.

I have livehttp and adblock installed.

Updated

14 years ago
Severity: normal → major

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
Has bug 259206 regressed again causing XML prettyprint to break again? If so, we
need to dupe this and reopen that. If not, then prettyprint is broken for some
other reason. This is the same testcase as bug 259206.
Keywords: regression

Updated

14 years ago
Summary: Xml prettyprint is not working → XMLl prettyprint is not working
Works for me with 2005-02-28 trunk build of Mozilla, so Firefox only.
Works in 2005-02-20 build.
Doesn't work in 2005-02-21 build.
Maybe this is a regression from fixing bug 279768?

Updated

14 years ago
Summary: XMLl prettyprint is not working → XML prettyprint is not working
(Assignee)

Comment 3

14 years ago
I don't think it's my fault. I did not touch prettyprint in between 2005-02-19
and 2005-02-22. 

Maybe bug 282792 - bryner did touch PrettyPrint there.

But I'll hold it on my radar and check it once more.

CC'ing bryner
(Assignee)

Comment 4

14 years ago
also, anything I could touch (prettyprint.dtd in fact) wasn't touched yet.

Btw. I do see the content of URL link, it's just not formatted. Reporter wrote
that he's window is "empty".
What are the build times for the succeeding and failing builds?
Flags: blocking-aviary1.1?
2005-02-20 build is from 7:13am
2005-02-21 build is from 7:33am
Checkin range (+3 hours on each side):

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-02-20+04%3A00%3A00&maxdate=2005-02-21+09%3A00%3A00&cvsroot=%2Fcvsroot

bryner's changes for bindings are not in this range.

Brief tests show that chrome://communicator/content/xml/XMLPrettyPrint.xml loads
fine in Firefox, but chrome://communicator/content/xml/XMLPrettyPrint.xsl gives
an XML parse error at:

  &xml.nostylesheet;

(no way to tell what the error is, because XML error messages are busted too,
apparently; is there a bug on this?).

Another brief test shows that chrome://communicator/locale/xml/prettyprint.dtd
doesn't load anything in Firefox (it loads the right thing in SeaMonkey).

Based on that, over to Gandalf.
Assignee: bugs → gandalf
OS: Windows 2000 → All
Hardware: PC → All
Ah, the XML error message thing is bug 283766.
So here's the question.  What does
chrome://communicator/locale/xml/prettyprint.dtd actually resolve to ?  The
jar.mn entry for prettyprint.dtd is:

en-US.jar:
  locale/en-US/communicator/xml/prettyprint.dtd  (locale/en-US/prettyprint.dtd)

and checking a firefox install that shows this problem, en-US.jar does contain
the file at locale/en-US/communicator/xml/prettyprint.dtd in the jar.  So is the
problem that the chrome URI is not resolving to the right thing, perhaps?

Comment 10

14 years ago
What's happening is quite simple, though I don't know how it got to this point:
there is no longer a contents.rdf file for communicator/locale. Since we are
trying to (re)remove the communicator package from firefox. The only four files
remaining in this package are

security/caps.properties
layout/xmlparser.properties
xml/prettyprint.dtd
webservices/security.properties

Gandalf, please add back the communicator contents.rdf file until you get these
moved to their final home.
(Reporter)

Comment 11

14 years ago
The page was empty because the xml i loaded did not contain any text-data
between tags, only attributes was present.

Updated

14 years ago
Blocks: 284955

Comment 12

14 years ago
*** Bug 284918 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

14 years ago
this one is fixed with my lastest checkin in bug 279768
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.