Javascript console pops up because of a javascript testing string

RESOLVED DUPLICATE of bug 243170

Status

defect
RESOLVED DUPLICATE of bug 243170
15 years ago
3 years ago

People

(Reporter: Jwebmonk, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

There is a line, in their script (in file
http://www.nutzandboltz.org/inc/script.js) that I assume works for some error
checking. The line is:

function onerror() { document.location.href = "javascript:"; }

This line, and any line that runs the command "javascript:" will make the
javascript console pop up. This should NOT happen, or should at least have some
way of turning the javascript console completely off.

Reproducible: Always

Steps to Reproduce:
1. Mouse over the menu on http://www.nutzandboltz.org
OR
1. Or make a blank page that has a line like <A HREF="javascript:">TEST</A>
2. and click the mouse on that link.
Actual Results:  
It then pops up a blank Javascript Console. Or in the case of nutzandboltz site,
pops up the Console with an error from somewhere else on the page.

Expected Results:  
Shouldn't have popped up the Javascript Console at all, or at least should have
a way to completely disable the Javascript Console regardless of what a webpage
may say or do.

*** This bug has been marked as a duplicate of 243170 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.