Closed Bug 284456 Opened 15 years ago Closed 13 years ago

Multiple Google and Amazon.co.uk entries in the search box in Firefox 1.0.x en-GB

Categories

(Firefox :: Search, defect, trivial)

defect
Not set
trivial

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: gkn, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

After installing Firefox 1.0 en-GB and waiting a few days, second Google and
Amazon.co.uk items appear in the search box. The problem manifests itself by the
new Google search item having no associated icon, so the Google logo in the
search box becomes the generic magnifying glass.

In the searchplugins folder are: google.src, google-uk.src, google-uk.gif,
amazondotcom-uk.src, amazondotcom-uk.png, amazoncouk.src, amazoncouk.png.

I assume this is to do with the automatic update system and mismatched names:

google-uk.src's update url is http://www.google.co.uk/mozilla/google.src
google.src's update url is http://www.google.com/mozilla/google.src
both amazoncouk.src and amazondotcom-uk.src have an update url of
http://mycroft.mozdev.org/plugins/amazoncouk.src

Reproducible: Always

Steps to Reproduce:
1.Install Firefox 1.0 en-GB
2.Wait
Confirmed here.  This is probably another manifestation of Bug 273752.
The workaround is to edit google-uk.src and change

   updateCheckDays=1

to 

  updateCheckDays=0

That'll stop it pulling the wrong one down every day.
(In reply to comment #1)
> Confirmed here.  This is probably another manifestation of Bug 273752.

It's the same sort of thing. The problem here is that the *default* search
plugin updates with the wrong (i.e. a different) search plugin.

Also, in the case of Google, the "wrong" search plugin doesn't seem to update
its icon. (This is probably a separate bug of near-zero importance.)
Also seen in 1.0.1 en-GB.
Summary: Multiple Google and Amazon.co.uk entries in the search box in Firefox 1.0 en-GB → Multiple Google and Amazon.co.uk entries in the search box in Firefox 1.0.x en-GB
I can confirm this for the google and amazon search plugins in both the exe and
zip builds of 1.0.3 en-GB.

In both cases the src file that the update url points to is different from the
original, so it is downloaded in addition to the original - as opposed to
replacing it.

Because the included google.co.uk search plugin does not have 'only search pages
from uk' set, it returns the same results as a google.com search. So, it could
just be replaced with the google.com search plugin in the FF releases.

As for amazon, the search url from the original src file and the src file the
update url points to is the same. Therefore, they could just replace the
included plugin with the plugin the update url points to.
Confirmed in 1.0.4 en-GB exe build
Seen in 1.0.3 en-GB.

-> New
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed in 1.0.6 en-GB exe build
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712
Firefox/1.0+

This has also been experienced here.
The summary of bug 299825 is "Don't change the directry when update."
The summary of this bug is   "Don't change the leafname when update."

So these two are requesting almost same thing.

->
"Don't change the directy and leafname (= fullpath) when update."
Depends on: 299825
OS: Windows XP → All
Hardware: PC → All
What does 'leafname' mean?
By "file leaf name" I mean the file name, not the full path.
I guess it'd come from "one of terminal ends of the directory tree".

The problem is that nsInternetSearchService guesses
the leaf name from engine's update url.

If the update url of "foo.src" is "http://www.example.com/foo/bar.src",
the new name would be "bar.src".
So we will have 2 engines named "foo.src" and "bar.src" after update.

The expected behavior is just to overwrite the contents of "foo.src".
And the search component should not create a new file named "bar.src",
regardless of the update url of "foo.src".

See also bug 299825 comment 21
That will solve the duplicate plugins problem, but the update path for the
google.co.uk plugin points to the google.com plugin.

the google.co.uk plugin would be replaced by the google.com plugin on the first
update.
(In reply to comment #13)
> the update path for the google.co.uk
> plugin points to the google.com plugin

That's bug 306576.
The new search service doesn't have an update system yet, but when it does it should not have this problem :)
Assignee: p_ch → nobody
Depends on: search-update
This bug is no longer relevant, given the new search plugin requirements and new search update system.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.