browser hangs when on http://www.bcis.com/waiting_times.shtml and will not close correctly

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
RESOLVED INVALID
13 years ago
7 years ago

People

(Reporter: Ben M, Assigned: Alfred Peng)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217

When I go to this page, the browser won't load the page and looks like it is
hanging (i.e. the animated 'M' in the upper right hand corner is stuck), but I
am still able switch tabs and select File->Exit.  That causes all of Mozilla's
windows to close, but doesn't kill the process.  When I go to the task manager,
I can see the mozilla.exe processing pegging the CPU at 99%.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.bcis.com/waiting_times.shtml
2.Observe
Actual Results:  
It hung like I wrote in the details section.
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050316
Reporter: Does this Problem still exists with your 1.8b ? If not please resolve
this Bug as WFM.
(Reporter)

Comment 2

13 years ago
>> WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
>> rv:1.8b2) Gecko/20050316  
>> Reporter: Does this Problem still exists with your
>> 1.8b ? If not please resolve this Bug as WFM.


Yes, it still does exist with 1.8b.
Version: unspecified → Trunk

Comment 3

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217

Try a clean install?
(Reporter)

Comment 4

13 years ago
>> Try a clean install?


I just did.  I uninstalled it, then I erased the mozilla.org directory (where it
had been installed), and then reinstalled it.  I still have the same exact problem.


The version I installed was "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8b) Gecko/20050217"

Comment 5

13 years ago
WORKSFORME

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050217
Java(TM) 2 Platform Standard Edition 5.0

The page contains a Java applet. Reporter, what version of Java do you have
installed? Enter 'about:plugins' in the address bar to find out.
(Reporter)

Comment 6

13 years ago
>> Reporter, what version of Java do you have
>> installed? Enter 'about:plugins' in the address
>> bar to find out.


It appears that I have Java 1.5 / 5.0 installed.  There are multiple entries 
for Java in the about:plugins list.  I don't know if this is correct or not, 
but I am pretty sure I only installed Java once.  I have pasted the relevent 
parts of about:plugins below.


---------------------------------------------------------------------



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPJava14.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.4.2 	Java Applet 		Yes
application/x-java-bean;version=1.4.2 	JavaBeans 		Yes
application/x-java-applet;version=1.5 	Java Applet 		Yes
application/x-java-bean;version=1.5 	JavaBeans 		Yes



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPJava32.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.3 	Java Applet 		Yes
application/x-java-bean;version=1.3 	JavaBeans 		Yes
application/x-java-applet;version=1.2.2 	Java Applet 		Yes
application/x-java-bean;version=1.2.2 	JavaBeans 		Yes
application/x-java-applet;version=1.2.1 	Java Applet 		Yes
application/x-java-bean;version=1.2.1 	JavaBeans 		Yes



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPJPI150.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;jpi-version=1.5 	Java Applet 		Yes
application/x-java-bean;jpi-version=1.5 	JavaBeans 		Yes



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPOJI610.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	Java 		Yes



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPJava11.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1.1 	JavaBeans 		Yes
application/x-java-applet;version=1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1 	JavaBeans 		Yes
application/x-java-applet 	Java Applet 		Yes
application/x-java-bean 	JavaBeans 		Yes



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPJava12.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.2 	Java Applet 		Yes
application/x-java-bean;version=1.2 	JavaBeans 		Yes
application/x-java-applet;version=1.1.3 	Java Applet 		Yes
application/x-java-bean;version=1.1.3 	JavaBeans 		Yes
application/x-java-applet;version=1.1.2 	Java Applet 		Yes
application/x-java-bean;version=1.1.2 	JavaBeans 		Yes



Java(TM) 2 Platform Standard Edition 5.0

    File name: NPJava13.dll
    Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.3.1 	Java Applet 		Yes
application/x-java-bean;version=1.3.1 	JavaBeans 		Yes
application/x-java-applet;version=1.4 	Java Applet 		Yes
application/x-java-bean;version=1.4 	JavaBeans 		Yes
application/x-java-applet;version=1.4.1 	Java Applet 		Yes
application/x-java-bean;version=1.4.1 	JavaBeans 		Yes

Comment 7

13 years ago
there's a preference in the Mozilla preference panel saying ENABLE JAVA.
Can you uncheck that box and try again?
(Reporter)

Comment 8

13 years ago
>> there's a preference in the Mozilla preference
>> panel saying ENABLE JAVA.  Can you uncheck that
>> box and try again?


That worked.  The page does not crash my browser when "Enable Java" is not checked.

Comment 9

13 years ago
(In reply to comment #8)
> That worked.  The page does not crash my browser when "Enable Java" is not
checked.


OK, that means the problem is Java related at least ;)
Moving to OJI.
Assignee: general → kyle.yuan
Component: General → Java: OJI
Product: Mozilla Application Suite → Core
QA Contact: general → oji

Updated

12 years ago
Assignee: yuanyi21 → pete.zha

Comment 10

12 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng

Comment 11

11 years ago
I checked that site. My 'Enable Java' is checked on. The browser doesn't gets crashed. 
No problem to my browser when I reopen the site in a new window/tab. 
:) 

Comment 12

11 years ago
according to archive.org the page is gone for almost 2 years
-> INVALID/untestable (or incomplete)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.