Stops responding when importing a calendar with lots of alarms

RESOLVED WORKSFORME

Status

Calendar
Internal Components
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Sam, Assigned: shaver)

Tracking

Details

Attachments

(1 attachment)

233.87 KB, application/octet-stream
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I open a .ics file with lots of alarms (~400), it takes a lot of time to
open the first six alarms. But when I click on "ack all", it stops responding.
Gave up after about 45 min. When I click on "ack" for one alarm, it took about 5
min the first tme. Waited over 15 min. for the second item and gave up.

Reproducible: Always

Steps to Reproduce:
1. open attached .ics file
2. wait forever to process all the alarms
3. click on "acknowledge all"
4. give up

Actual Results:  
frozen

Expected Results:  
closed the alarms window within a reasonable time
(Reporter)

Comment 1

13 years ago
Created attachment 176058 [details]
.ics that exhibits the bug

Comment 2

13 years ago
Reporter:
    This looks like it's probably a version of bug 198142 (Calendar has trouble
with very large ics files), but it may also be related to bug 229916 (many
expired alarms cause calendar to crash).  If you don't mind, could you try
removing the alarms using another program, and then importing the file again. 
If calendar is still very sluggish, then it's probably bug 198142, and should be
marked as a duplicate.  If not, perhaps you can try to find a critical number of
alarms at which calendar crashes?
(Reporter)

Comment 3

13 years ago
I just tried by first disabling the expired alarms from the Edit->Preferences
before opening the calendar file. It opens without delay. 

Also, it doesn't quite crash. Just seems to takes a looong time to respond. 

Comment 4

12 years ago
Not sure if this is the same bug, but im trying to delete alot of events (400+) and im getting the same symptoms

Comment 5

12 years ago
(In reply to comment #3)
> I just tried by first disabling the expired alarms from the Edit->Preferences
> before opening the calendar file. It opens without delay. 
> 
> Also, it doesn't quite crash. Just seems to takes a looong time to respond.
Alarms in current versions now should import without this problem.  Please feel free to re-open this bug if you can reproduce it with a current nightly build. 

(In reply to comment #4)
> Not sure if this is the same bug, but im trying to delete alot of events (400+)
That's a different bug.
> and im getting the same symptoms
> 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.