Going up/down a menu with keyboard causes disabled items to be selected without visual notification

RESOLVED WORKSFORME

Status

()

Firefox
Disability Access
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Dan Fischbach, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)

When scrolling up or down a program menu (File, Edit, etc.) or a context menu
with the arrow keys, Firefox still acts as if a disabled item is
highlightable/selectable.  It does not show it, but you can tell if you arrow
up/down a menu.  For example:

Example Menu:
+----------------+
| Enabled item   |
| Disabled item  |
| Enabled item   |
+----------------+

If you highlight the first enabled item, you must key down TWICE to reach the
second enabled item.  This also happens for multiple items that are disabled
(wether they are in a row or not).

Reproducible: Always

Steps to Reproduce:
1. Open a menu
2. Key up/down until you reach a/some disabled items
3. Key up/down until you can reach another enabled item

Actual Results:  
Nothing.

Expected Results:  
Firefox should go DIRECTLY to the next enabled item.

Comment 1

13 years ago
Isnt that the normal behavior on windows? Just try any other windows app and it
will work as in Firefox
(Reporter)

Comment 2

13 years ago
Hmmm...yeah, it seems to be the default, but Firefox does not highlight the
background of the item as another program did.  MS Word 2k3 highlights disabled
items by having the background transparent, but leaves the border.

Pick whichever works, or use my original recommendation.
Summary: Going up/down a menu with keyboard causes disabled items to be "highlighted" → Going up/down a menu with keyboard causes disabled items to be selected without visual notification

Comment 3

13 years ago
WFM.  When arrowing through the View menu, the Stop item gets a blue background
when it is selected.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050303
Firefox/1.0+
Default Firefox theme
Windows XP "Classic" theme

Comment 4

13 years ago
MS Word 2k3 uses a totally different layout for menues. This is also WFM.

--> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 years ago
OK.  Sorry about all this.  It seems it was the theme I'm using (Noia 2.0
eXtreme v2.82).  I will notify the author.  Thanks for checking this out. 
Again, sorry for wasting your time as I know you guys have a lot more important
things to do.

Dan
You need to log in before you can comment on or make changes to this bug.