the accent in the address bar should become %e9 instead of %C3%A9

VERIFIED DUPLICATE of bug 284474

Status

()

defect
VERIFIED DUPLICATE of bug 284474
14 years ago
14 years ago

People

(Reporter: psyk_x, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050301 Firefox/1.0+

In the page at http://aggimq.ca/?page=mot_du_président, the accent é is url-
encoded in the wrong character set, %C3%A9, when it should actually be %e9 . 
The current url-encoding makes it impossible to display the good page and the 
problem is NOT from PHP, as I tried in Internet Explorer and it works well 
(but I know they do not always url encode stuff like firefox does)

Reproducible: Always

Steps to Reproduce:
1.click on the link on the left that brings you to the "Mot du président" page
2.now replace the %C3%A9 in the address bar to %e9 to actually get the good 
page...

Actual Results:  
the é in the address bar is replaced by %C3%A9

Expected Results:  
the é in the address bar should be replaced by %e9
Reporter

Comment 1

14 years ago
é should be an ecute in the bug report, not an A with a ~ followed by a 
copyright sign. I don't know why it changed my ecute accent with these 
though... Maybe firefox interprets it the same way and that is why it doesn't 
work?

Comment 2

14 years ago
Dupe of bug 284474. Work-around: go to 'about:config' and set
'network.standard-url.encode-utf8' to false.

When you wrote your comment #0, View | Character Encoding was set to UTF-8
(which was the right thing to do whenever you enter non-ASCII characters in
bugzilla). On the otherhand, when you view your comment #0, it was set to
Western(ISO-8859-1). Setting it to UTF-8 will solve the problem you described in
comment #1. 


*** This bug has been marked as a duplicate of 284474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Reporter

Comment 3

14 years ago
Woops, you're right. I am not very familiar with encodings. When I develop 
websites it's just that it works or it doesn't work.

Sorry if it was already posted, I have searched but couldn't find :(
You need to log in before you can comment on or make changes to this bug.