Preferences: Japanese author's name is not saved properly.

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: ji, Assigned: ftang)

Tracking

Trunk
All
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+ ETA 3/2)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Build: 2000021808 linux and windows build.

On the preference window for composer, Japanese characters for the author's name
are not saved correctly.

Steps of reproduce:
1. Launch mozilla.
2. Select Edit | Preferences...
3. On the preferences window, select Composer.
4. Enter Japanese characters for the Author Name field and click on Ok to
   save it.
5. Go back to that composer preferences window again.
   You'll see the Japanese author name is not save correctly.
Open the pref.js file, you can see the author's name is not saved in utf8.

Comment 1

19 years ago
I'm thinking that this has not been implemented yet and 
that the right place to deal with this bug may be in Bug 7067.
C''ing selmer and varada.

Updated

19 years ago
Assignee: ftang → neeti

Comment 2

19 years ago
This seems more like a prefs bug from the description of the problem.  
Basically, you're asking for the prefs file to be saved/restored using a 
different format than it currently uses.  I think Neeti should take first crack 
at saying what to do with this bug, so I'm reassigning this to her. 

7067 was primarily targeted at platform differences.  Maybe I18N concerns could 
go there, but I'm not convinced.

Comment 3

19 years ago
Could someone tell me how to enter Japanese characters?

Thanks,
Neeti
Status: NEW → ASSIGNED

Comment 4

19 years ago
For your purpose, copy/paste might be enough.

Assuming that you have US Windows, here's what you can do:

1. Make sure you have a font which has Japanese glyphs. If you not, go get Cyberbit font from:

   ftp://ftp.netscape.com/pub/communicator/extras/fonts/windows/

   Get "Cyberbit.ZIP". Unarchive it. And use Control Panel | Fonts | File |Install new font
   to install this font.

2. Right now, copy/paste from Mozilla browser window does not seem to be working. So,
   Use 4.7x. To use the above font for Japanese, set: "Edit | Prefs | Apperance | Fonts |
    for the encoding | Japanese - fixed & variable" to Bitstream Cyberbit.

3. Go to the following page first having set: "View | Character Set | Japanese (Shift_JIS)"
   in 4,7x.

   http://kaze:8000/data/jpnname.html

4. You see 4 Japanese/Kanji characters there.  Copy these.
5. Open Mozilla pref window and paste the string in step 4 into a field of your choice.

Comment 5

19 years ago
Created attachment 5531 [details]
JPG image of a Japanese name (4 characters) at: http://kaze:8000/data/jpnname.html

Comment 6

19 years ago
If you want to use Global IME to input Japanese under US Windows, you can read 
the instructions here:

http://rocknroll/users/momoi/publish/Nova/novaactveime.html

Comment 7

19 years ago
Thanks for the information.  I was able to paste the Japanese characters from http://kaze:8000/data/jpnname.html into
 Edit | Preferences | Composer | Author Name field .  It is currently getting saved into prefs.js as 
user_pref("editor.author", "q0±P ");

Neeti

Updated

19 years ago
Assignee: neeti → matt
Status: ASSIGNED → NEW

Comment 8

19 years ago
Matt,

When we set pref "editor.author", the frontend is using nsPref::SetCharPref(..) to set the pref.
  It should be using nsPref::SetUnicharPref(..) to convert it to utf8 string.

Neeti
(Assignee)

Comment 9

19 years ago
here is the patch
RCS file: /m/pub/mozilla/xpfe/components/prefwindow/resources/content/pref.js,v
retrieving revision 1.9
diff -c -r1.9 pref.js
*** pref.js     2000/02/17 21:23:19     1.9
--- pref.js     2000/02/25 18:15:50
***************
*** 211,217 ****
        case "string":
        case "color":
          try {
!           var charPref = whp.CopyCharPref( elementObject.prefstring );
          }
          catch(e) {
            var charPref = "";
--- 211,217 ----
        case "string":
        case "color":
          try {
!           var charPref = whp.CopyUnicharPref( elementObject.prefstring );
          }
          catch(e) {
            var charPref = "";
***************
*** 223,229 ****
            break;
          }
          if( charPref != elementObject.value )   // do we care about whitespace
?
!           whp.SetCharPref( elementObject.prefstring, elementObject.value );  /
/ string pref
          break;
        default:
          // TODO: insert implementation for other pref types;
--- 223,229 ----
            break;
          }
          if( charPref != elementObject.value )   // do we care about whitespace
?
!           whp.SetUnicharPref( elementObject.prefstring, elementObject.value );
  // string pref
          break;
        default:
          // TODO: insert implementation for other pref types;
***************
*** 329,335 ****
          case "string":
          case "color":
            try {
!             var prefvalue = this.pref.CopyCharPref( prefstring );
            }
            catch(e) {
              continue;
--- 329,335 ----
          case "string":
          case "color":
            try {
!             var prefvalue = this.pref.CopyUnicharPref( prefstring );
            }
            catch(e) {
              continue;
Add rjc to the cc list since he have similar issue in the search pref.
(Assignee)

Comment 10

19 years ago
the patch is here. Please reconsider take this as beta1
Without it, people cannot put their name for composer/mail/news
Keywords: beta1

Comment 11

19 years ago
Putting on PDT- radar for beta1
Whiteboard: [PDT-]

Comment 12

19 years ago
Please econsider for PDT+ from Frank's comment.
Whiteboard: [PDT-]

Comment 13

19 years ago
frank i'm giving this bug to you since you have the fix
The fix should be very safe.

Updated

19 years ago
Whiteboard: PDT+

Comment 14

19 years ago
Reassigned to ftang per matt's last comment
Assignee: matt → ftang
Whiteboard: PDT+ → PDT+ ETA 3/2
(Assignee)

Comment 15

19 years ago
fix and check in.
Status: NEW → ASSIGNED
(Assignee)

Comment 16

19 years ago
fix and check in
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 17

19 years ago
Verified this in 2000030609 Linux and Win32 and 2000030708 Mac build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.