Closed Bug 284653 Opened 15 years ago Closed 7 years ago

Search field not focused by default in bookmark and history library

Categories

(Firefox :: Bookmarks & History, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: markjoel777, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

When opening the bookmark manager, the cursor does go to the search text field
by default. If this is by design, then there should be a place to select the
default location.

Reproducible: Always

Steps to Reproduce:
1.Click Bookmarks
2.Manage Bookmarks
3.

Actual Results:  
Bookmark manager opens, but cursor is not in the Search field

Expected Results:  
Cursor should be in the Search field by default
Does it same for Windows 98 
This is a reasonable enhancement request. but why don't you want the Bookmarks
manager to com back up just how you left it?
(In reply to comment #1)
> Does it same for Windows 98 

I have not tried it using Win98, only WinXP Pro.
That is what I entered in the OS field when I submited the report.
(In reply to comment #2)
> This is a reasonable enhancement request. but why don't you want the 
Bookmarks
> manager to com back up just how you left it?

Ben,

For usability, when opening the Bookmark Manager, I just want to perform a 
quick search.

Normally, other users will have created bookmark folders, but if I search as 
it currently functions, the only hits that I will get are from the folder 
names.

However, when searching with the Search field, it shows all occurrences 
whether in one or multiple folders.
(In reply to comment #4)
> (In reply to comment #2)
> > This is a reasonable enhancement request. but why don't you want the 
> > Bookmarks manager to com back up just how you left it?
> 
> Ben,
> 
> For usability, when opening the Bookmark Manager, I just want to perform a 
> quick search.

I agree that the Bookmarks system has numerous useability problems
and is unable to handle a bookmarks file with more than 300 to 500
entries.

I agree that an approach that is often successful is to make small
evolutionary improvements, but I suspect that a complete
re-implementation is needed here.

I differ from you, probably irretrievably on your stated objective
when you speak of the Bookmark manager's coming up in a certain way
every time.

Have you thought of creating a markjoel extension that did exactly
what you want, and did nothing else?

Is the sidebar of any use to you. Hit Cmd-B (Cmd-Shift-B would be
more consistent and free Cmd-B to open the Bookmarks Manager) and
type your search term.
> I just want to perform a quick search.
hit ctrl-b and be happy to do a quick search immediatly

i dont think this bug is a bug - i like that typing a letter brings me to the
bookmark starting with it.

and, simply hit tab in the manager and you're in the search bar text field.

imho this bug should be closed as "will not fix" or "is not a bug"
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
I can reproduce this, too, but it sounds like the path forward is unclear.  Ben's control-b suggestion seems to produce the expected behavior, so... Won't Fix?
I'm fairly sure this is "by design", however, I'll confirm it as a valid RFE and re-summarize. I'm also not sure this bug even matters given the UI will change for Places.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: bookmark manager - search text field is not active by default. → Search field not focused by default in bookmark manager
this is also relevant for history search in library
Summary: Search field not focused by default in bookmark manager → Search field not focused by default in bookmark and history library
we want the right pane of the library to have focus for screen readers (for example when opening Downloads we want the screen reader user to end into the downloads list), so this is wontfix since it's working as expected.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1040730
Marco: Hopefully you can consider reopening this. There likely is a way that doesn't hinder the tiny amount of screen reader users while allowing the deserved convenience for the majority.

First idea: let the right pane be focused first, but make typing any character focus the search field and insert the character there. Currently typing any key when the right pane is focused doesn't do anything, so this doesn't hinder any current behavior.

Both win: screen reader users keep the focus they are used to, and everyone can search conveniently.
Duplicate of this bug: 1060306
Duplicate of this bug: 1340241
I'm one of those who also requested this in Bug 1017597 so I'm not satisfied with WontFix and also think this should be done, as Joni explained.
Duplicate of this bug: 1393952
Duplicate of this bug: 1596480
You need to log in before you can comment on or make changes to this bug.