Form Manager difficult and awkward to use

RESOLVED WORKSFORME

Status

SeaMonkey
Preferences
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Tom Schneider, Unassigned)

Tracking

1.7 Branch
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.3) Gecko/20040919
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.3) Gecko/20040919

When I try to edit the form information I find it difficult
to remove an item easily.

It is also impossible to change multiple items at once without
restarting the whole process.  This is a terrible waste of time.

Reproducible: Always

Steps to Reproduce:
1.Go to the Tools/Form manager/Edit form info
2.delete the contents of an item
3.hit enter

Actual Results:  
The entire form disappears. 

Expected Results:  
The form should still be there so I can delete the 200 other stupid
things that got into the form information!
Version: unspecified → 1.7 Branch
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

12 years ago
This is still a MAJOR problem with SeaMonkey.  It is a total pain
to edit the forms.  I basically have given up.  On occasion I consider
deleteing everything and retyping all my information and then never saving
but that would only shoot me in my foot.

If I were just starting and hit this I would give up on the project.

It should be CRITICAL.

Comment 3

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

I can't reproduce this bug.

I close this for now as wfm.
Reporter, if you still run into this problem while using an recent Build,
please reopen and submit actual information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 4

10 years ago
Well the situation is worse than that now.  I can't even DELETE an item at all!
There is all kinds of junk in the Prefix for my Name.  I go to an item,
delete the corresponding text.  it's still in the list!  I delete the text and click OK and return to it and it's still there.  This bug is WORSE than before.  Try to put 5 or 6 items for your first name and then try to remove one.
It is NOT OBVIOUS how to remove an item and they keep coming back.

This bug is NOT resolved.
Thanks for looking at it after all this time.  I find it amazing that terrible bugs like this are not being resolved.  I've put out many notifications of bugs
in this otherwise wonderful browser and they aren't being fixed.  Is it that people stopped working on it for some reason?

Comment 5

10 years ago
I am used SeaMoneky 1.1.9 in FedoraCore7, in new profile.
It is work fine.

Please, you testing this bug in new profile. 

Who use version SeaMonkey (Help-About SeaMonkey)?

Comment 6

10 years ago
I tried a completely new profile.  I was indeed able to add and remove some items.
But it is totally awkward.  Further, why should my old profile, which I do not want to delete, give me so much trouble?

This entire thing has to be rebuilt from the ground up.  Having dropdown menus
is VERY awkward.  It is hard to see what one has done and clicking 'OK' makes
it all go away.  Editing many of the entries all at once is a total pain.

Please revamp the entire design of this thing.  It's horrible.  I keep getting bad entries into it by accident or even when I intend to.  The entries should be fixed to particular web sites but are instead general and since different web sites use different definitions, they override each other and generate a complete mess.

Comment 7

9 years ago
It's revamap for SeaMonkey 2.0 (Trunk version). See https://wiki.mozilla.org/SeaMonkey:New_for_2.0#New_Features (Form Manager replaced by Satchel)
You need to log in before you can comment on or make changes to this bug.