Query for UNCONFIRMED returns a bug report in NEW state

VERIFIED FIXED in Bugzilla old

Status

()

P3
normal
VERIFIED FIXED
19 years ago
6 years ago

People

(Reporter: 3jrgm, Assigned: terry)

Tracking

unspecified
Bugzilla old
x86
Windows 95

Details

(URL)

(Reporter)

Description

19 years ago
Noticed this bit of "teething pain" for the new UNCONFIRMED state.

The URL in the bug_file_loc for this bug report is the result of a
query.cgi, where I selected UNCONFIRMED for status, and sorted by Bug
Number (although the sort is not the issue). [All other fields were
left as the default value].

I get back 28 bugs (at this time). If you look through the list you
will see bug #28421.

Click on that bug report, and you'll see that it's actually in the NEW
state, and the assigned to field is now karnaze (not troy as it
appears in the query result set).  [I was the one who confirmed the
bug and reassigned to karnaze/HTMLFrames].

Not sure why the query result set is returning the stale information
(and I quit Nav4.7, deleted my cache, restarted and re-ran the query
-- I still see the wrong info in the result set -- so not a cache issue).

Thanks again, John

p.s. I did look for a dupl, but could not find one.
p.p.s. I get the same result set using either Nav4 or mozilla
(Reporter)

Comment 1

19 years ago
So, now I see that running this query does not return bug 28421 in the result
set. Perhaps I was hitting a database cache (new code?) or some temporary 
quirk.

If the transient nature of this "bug" makes sense to you, then just mark this 
as WORKSFORME and I'll VERIFY. (Perhaps I should look at more of the code, but 
if this is 'by design' then toss me a quick explanation :-]). 
(Assignee)

Comment 2

19 years ago
My apologies.

I was repairing a database inconsistancy I caused a couple of days ago.  I chose
a poor repair technique, and it caused the read-only shadow database (which is
used for reports queries) to lag many hours behind the real database (which is
used for everything else).

I fixed it last night.  I'm very sorry for the confusion.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

19 years ago
Hey. No apologies necessary. (When I saw this automagically correct itself, I 
figured there was some kind of db cache -- or in this case a read-only shadow
database (see, I learned something new about Bugzilla)). Thanks. John.
Status: RESOLVED → VERIFIED
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.