If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Script Debugger is not able to detect the script errors

RESOLVED INVALID

Status

Toolkit Graveyard
Error Console
--
major
RESOLVED INVALID
13 years ago
a year ago

People

(Reporter: Srinivas Sriram, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: 

This issue rises only in mozilla fire fox, and in IE this issue may not rise.
There are some options("Enable Script Debugging" and "Display notification of 
scripting errors") in advanced properties of IE whether to display the run time 
error(popup) or error on page(shown on the status bar)

Reproducible: Always

Steps to Reproduce:
1. Open any website.
2. If any "runtime" or "error on page" (this will be shown in the status bar of 
the IE) errors are not showing.
3. For these kinds of errors It is required to check agian in IE.
4. This doubles my work.

Actual Results:  
Not displaying any Script errors.

Expected Results:  
It must display script errors.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
You bug report is a little bit confusing (and one of the important things are
missing : The Firefox Version)
Do you have a problem that there are no errors shown in the Javascript console
(that works for me in FF1.0.1) or Do you want an enhancement bug that there
should be an option for a popup with such errors ?

Comment 2

13 years ago
we don't currently support the microsoft script debugger, but you can use our
javascript debugger, this is either invalid because you're confused, worksforme
because there's a debugger you could use, a duplicate of a bug to add support
for the ms debugging apis, or hopefully a duplicate of some bug asking for an
indicaton that there were errors relating to scripts in the current page.

Comment 3

13 years ago
Marking invalid. Reporter, if you have specific suggestions, search bugzilla and
if you don't find it, feel free to reopen this bug, but add a clear description
of what this bug is about.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.