table row displays incorrectly when toggle style:display

RESOLVED DUPLICATE of bug 97506

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 97506
13 years ago
13 years ago

People

(Reporter: QuasiEvil, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Table row has cells which do not line up with their respective columns when
toggled using javascript.

Please take a look at my page.  Click on the little orange button that says sort
controls.

This page is a table with row that is set to display:none in a stylesheet.  I
use javascript to set display:block onclick a button (image) that reads sort
controls.  The row appears in the right place however it's cells do not align
with the right columns.  

tested on WinXP firefox 1.0 and Mac OS X firefox 1.0.  On i.e. it works fine. 
Safari, btw, also has this bug.

Usually I would think I.E. would be the culprit and that I'm violating a
standard but i think in this case, the row cannot be considered a table anymore
since a table requires by defn. rigid widths for cells of the same column.

Reproducible: Always

Steps to Reproduce:
1. create table, external stylesheet
2. in stylesheet set one of the rows to display:none
3. using javascript, write a simple function to set display:block
3. use an anchor to trigger the function for said (hidden) row 

Actual Results:  
i reproduced the above bug

Expected Results:  
row should appear, all cells should line up with their respective columns

Comment 1

13 years ago
Default value of the table row is "table-row", instead toggle between "none" and
"" for a cross-browser solution.

*** This bug has been marked as a duplicate of 97506 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.