If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

using FlasVars in embed tags fails to validate in w3c

RESOLVED DUPLICATE of bug 161891

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 161891
13 years ago
13 years ago

People

(Reporter: ale.pas, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

FlashVars attribute in embed tag is needed to pass parameters to the movie but
this breaks w3c validation.

There is not another way to pass FlashVars, since the object tag is ignored by
firefox.


Reproducible: Always

Steps to Reproduce:
1.Go to www.trekking.it
2. Try to validate the page in w3c validator

Actual Results:  
Among other minor issues (like &->&) you see "
there is no attribute "FLASHVARS" <embed FlashVars="imagepath=images/homepage...


Expected Results:  
Why don't you support w3c standard object tag for flash embedding?

Comment 1

13 years ago
Mozilla does support flash embedding via OBJECT -- have you looked at the
example at:

http://www.mozilla.org/newlayout/testcases/printing/misc/embed_obj_tag.html

There are, however, sone known object element problems associated with flash --
basically to do with how PARAM elements aren't properly handled by the plugin.
See bug 161891 for details.

I suspect that this report is a dup of bug 161891 -- note comment 24 of bug
161891, which points out that it is Macromedia's fault that flash doesn't work
with object elements.
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 161891 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.