Colors of attached HTML are used for text part of message.

RESOLVED DUPLICATE of bug 76804

Status

RESOLVED DUPLICATE of bug 76804
14 years ago
14 years ago

People

(Reporter: cstef, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041217

I have preferences to compose messages in plain text format, View->Display
Attachments Inline is On and View->Message Body As set to 'Original HTML'. When
I compose a message to myself with attached HTML page which has background and
text colorsset to something differnet from default, these colors are used fro
displaying text part of the message, which is annoying. And this may mask the
text part if you set them both to the same value.

Reproducible: Always

Steps to Reproduce:
1. Compose plain text message with any text and attach HTML page with some
colors as background and text colors (for example, a.html from the first
attachment).
2. Set 'View->Display Attachments Inline' to on and View->Message Body As to
'Original HTML'.

Actual Results:  
You will see your text part of the message drawin with the colors from html
(with a.html it will be green on red).

Expected Results:  
Mozilla should use colors specified in HTML only for the part of mail window
that shows the attachment, and them text part of the message should be drawn
with default colors (black on white by default).

When I change View->Message Body As to 'Simple HTML' or 'Plain Text' the colors
disappear and I see it in proper colors. But for some complex HTML attachments
(i.e with tables) sometimes it is needed to look at them as Original HTML.
(Reporter)

Comment 1

14 years ago
Created attachment 176246 [details]
HTML file that can be attachem to message to see the problem

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 76804 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.