Typo in perl script regexp causes platform to be incorrectly identified as Unix when building installer under Windows/Cygwin/OS2

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: dave127001, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20050211
Build Identifier: N/A (FIREFOX_1_0_1_RELEASE tag)

There is an extraneous leading space (presumably a typo) in the perl regexp used
to identify the OS under which the installer is being built in the following
script file: mozilla/toolkit/mozapps/installer/build_static.pl

Quite simply, this line:
$win32 = ($^O =~ / ((MS)?win32)|cygwin|os2/i) ? 1 : 0;
should read:
$win32 = ($^O =~ /((MS)?win32)|cygwin|os2/i) ? 1 : 0;

Although it may seem like a bit of an overkill, I nonetheless created a patch
file in the format preferred by Mozilla.org, as specified in the guildelines for
patch file submission.  I had never used CVS before, so it was worth the
learning experience. :-)


Reproducible: Always

Steps to Reproduce:
N/A
'MSWin32' !~ / MSWin32/
(Reporter)

Comment 1

14 years ago
Created attachment 176306 [details] [diff] [review]
patch to mozilla/toolkit/mozapps/installer/build_static.pl
(Reporter)

Comment 2

14 years ago
Oops!  I failed to explicitly state that the result of incorrectly detecting the
platform in $(MOZ_SRC)/toolkit/mozapps/installer/build_static.pl is that the
installer _WILL NOT_ build under Windows (i.e., this is not merely a cosmetic
issue).  CVS tag: FIREFOX_1_0_1_RELEASE

Comment 3

13 years ago
you have to ask for review on patches so that they have a chance to get checked in.
Assignee: chase → nobody
Status: UNCONFIRMED → NEW
Component: Build Config → Build Config
Ever confirmed: true
Product: Firefox → Toolkit
QA Contact: bryner → build-config
Comment on attachment 176306 [details] [diff] [review]
patch to mozilla/toolkit/mozapps/installer/build_static.pl

Since the reporter never responding, I'm taking the liberty to request first-review from bsmedberg since this code is still unchanged in trunk.
Attachment #176306 - Flags: first-review?(benjamin)

Comment 5

13 years ago
Comment on attachment 176306 [details] [diff] [review]
patch to mozilla/toolkit/mozapps/installer/build_static.pl

But obviously the installer *does* build, so I'm not sure what the issue is.
Attachment #176306 - Flags: first-review?(benjamin) → first-review+
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> (From update of attachment 176306 [details] [diff] [review])
> But obviously the installer *does* build, so I'm not sure what the issue is.
> 

My dated response is that it did not build on Windows when I reported this.  I don't know whether this has been fixed as I'm no longer using Windows.  By installer, I meant the self-extracting installer.
since the installer builds marking wfm
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.