###!!! ASSERTION: invalid divisor: 'Error', file nsTableFrame.cpp

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Mats Palmgren (vacation - back in August), Assigned: Bernd)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
All
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

###!!! ASSERTION: invalid divisor: 'Error', file nsTableFrame.cpp

STEPS TO REPRODUCE:
1. load attached testcase in a debug build


http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/tables/nsTableFrame.cpp&rev=3.610&root=/cvsroot&mark=3639#3603
Created attachment 176333 [details]
Testcase
BTW, did I get the colors right? - I see that they are different in Opera ;-)
(Assignee)

Comment 3

13 years ago
its a dupe of or at least dependent on bug 197391
Depends on: 197391

Comment 4

12 years ago
confirmed on windowsxpsp2 in deerpark cvs build from 2005-07-02. also found on
nba.com. OS->ALL
OS: Linux → All

Updated

12 years ago
Blocks: 323500

Updated

12 years ago
Keywords: assertion

Updated

12 years ago
Blocks: 306939

Comment 5

10 years ago
I hit his assertion frequently.

Comment 6

10 years ago
I hit this assertion frequently.

Comment 7

10 years ago
Created attachment 278084 [details] [diff] [review]
shot in the dark

I think the colors in the testcase are reversed. IE 6, IE 7, Safari, and Opera all render the table as red, not green.

Anyways, the attached patch takes care of the assertion and causes us to render the testcase identically to the above browsers. On more complicated testcases, with an "empty" row followed by a row with style height, IE 6 and 7 both do their own (completely weird) thing, while this patch gives us parity with Opera and Safari on the more complex case.

Warning: comment in the patch is probably completely bogus.

Comment 8

10 years ago
Created attachment 278088 [details]
more complex case: 25px

On this, Safari and Opera (and us w/ patch) render identically.

Comment 9

10 years ago
Created attachment 278091 [details]
more complex case: 25%

Safari and Gecko render this identically with the 25px case.
Opera's rendering is completely different than the 25px case, closer to IE 6 and IE 7.
IE 6 and IE 7 render this the same as with their own rendering of the 25px case, which is not the same as Safari and Gecko's rendering.

Whee edge cases.
I suspect the correct behavior here involves a balancing algorithm that looks a lot more like the way we do width distribution than the current code does; some ideas in bug 359481.

That said, that isn't going to happen for 1.9, so small fixes that improve behavior are still welcome.

If you want review on the patch, please use the patch flags to request it.

Comment 11

10 years ago
Comment on attachment 278084 [details] [diff] [review]
shot in the dark

Okay, yeah, this patch is more or less completely bogus.

Bernd is right, this bug is pretty much a dupe of 197391. Moving future work there.
Attachment #278084 - Attachment is obsolete: true

Comment 12

10 years ago
FIXED by the patch in bug 197391.
Assignee: nobody → bernd_mozilla

Comment 13

10 years ago
I checked in the first testcase as a crashtest.  Do the other testcases want to be crashtests or reftests, or are they covered by Ben's set of reftests?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.