Firefox/mozilla needs to have an integrated pdf viewer

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
14 years ago
7 years ago

People

(Reporter: joekowalski, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

It would be really, really, really nice if Mozilla/firefox could have integrated
pdf viewing capabilities.  For the most part, Acro---- is a steaming pile of
**** that really only has lasted as long as it has because noone has bothered
to make something better.  The vast majority of the backend code is there and
multi-platform capabable as xpdf works well in many environments.  The hard part
would be wrapping it up into an XUL interface and integrating it into the rest
of the browser.  

Reproducible: Always

Comment 1

14 years ago
This is a likely won't fix. It is a lot of work for software that a third party
provides that is adequate. Adobe reader 7 is a lot better preforming than 6
especially if you choose the dial-up download of 7.
You are free to write a better pdf plugin.
There is no reason to integrate it into Firefox itself (adding bloat and there
are no resources for that)

-> wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED

Comment 3

7 years ago
This is solved by Bug 714712
You need to log in before you can comment on or make changes to this bug.