Want option to limit the number of simultaneous downloads.

VERIFIED DUPLICATE of bug 258027

Status

()

Toolkit
Downloads API
--
enhancement
VERIFIED DUPLICATE of bug 258027
13 years ago
10 years ago

People

(Reporter: John David Galt, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

When multiple files are selected for download, the browser insists on trying to
download them all at once.  Not all web sites allow this behavior, and when it
is allowed it bogs down both the local and remote machines.  The only
alternative at present is to sit in front of the machine, waiting for each
download to finish and then manually starting the next.  It would be nice if
there were an options setting that would tell Firefox to attempt to download
only up to (n) files at a time.  Then I could request several downloads from a
web or ftp/gopher site and have Firefox fetch them sequentially rather than in
parallel.  I won't have to babysit the PC during a multiple-hour download
session and the site-owner won't be annoyed at me for hogging his bandwidth.

Reproducible: Always

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 258027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.