TXT-HTML Conversion for numbered lists omits initial spaces

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
20 years ago
15 years ago

People

(Reporter: akkzilla, Assigned: bratell)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
Send a plaintext message to yourself that looks something like this:

Here is a list:
     1. one
     2. two
     3. three

(I did this by making a numbered list in html compose, then having it convert to
plaintext on send.)

Now view this message in mozilla.  The spaces in front of the first list item
aren't shown: it looks like:
1. one
     2. two
     3. three

View it in 4.x or save it to disk to verify that the spaces are really there.

This is probably a layout issue, but it only happens in the mail window; if I
save to disk as test.txt and run the browser on that file, I see the spaces.

Comment 1

20 years ago
Reassign to rhp
Assignee: phil → rhp

Comment 2

20 years ago
Hi Akkana,
If you don't own this converter, please just reassign. Though the bug talks 
about a mail sending operation, it boils down to an issue with HTML - TXT 
conversion.

Thanks!

- rhp
Assignee: rhp → akkana
Summary: mail window doesn't lay out leading spaces → HTML-TXT Conversion for numbered lists omits inital spaces

Updated

20 years ago
Summary: HTML-TXT Conversion for numbered lists omits inital spaces → HTML-TXT Conversion for numbered lists omits initial spaces
Target Milestone: M15
Reporter

Comment 3

20 years ago
Changing the summary -- it's apparently text-html conversion that's causing
problems, because the plaintext from the original html is fine when viewed in
4.x.

I own html->text (technically, anyway, though Ben and Daniel help a lot on it
and own some of the code) but I don't know much about text->html -- that's Ben's
area, isn't it?  Assigning back to Rich and cc'ing Ben.
Assignee: akkana → rhp
Summary: HTML-TXT Conversion for numbered lists omits initial spaces → TXT-HTML Conversion for numbered lists omits initial spaces
I have no idea, what in my code could cause this. It doesn't even know, if it's
the first or the second line.
I can't reproduce it using a build from 2000-02-17 with format=flowed.

I can't test plain text, because Mozilla throws out all preferences I manually
add to prefs.js ("user_pref("mail.send_plaintext_flowed", false);" in this
case).

Comment 6

20 years ago
Will investigate further.

- rhp
Status: NEW → ASSIGNED

Comment 7

20 years ago
Hi Daniel, I can recreate this issue pretty easily. Just compose an HTML message with a numbered list and then from the Options->Format menu, select "Plain Text Only". Now when you send it and receive it with Mozilla, you will see that the first line is over to the left column. I traced it into mozilla/mailnews/mime/src/mimetpfl.cpp and found that we get to the section in MimeInlineTextPlainFlowed_parse_line() where we are replacing single spaces with   but when we hit this first line, exdata->inflow has been set to TRUE so we don't do the replacement. I'd rather have you look at the problem since you understand this logic much better than I do. - rhp
Assignee: rhp → bratell
Status: ASSIGNED → NEW
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Assignee

Comment 8

20 years ago
I can't reproduce this. When following the description rhp wrote I get:
BEGIN ------------- BEGIN
A list

   1. One
   2. Two
   3. Three
END ------------- END

It's like that in the Inbox file and on screen. 



      
Assignee

Comment 9

20 years ago
Note that there are no spaces at the end of the lines in the mail in the Inbox 
file except for the line after the list. rhp, could you please check if you have 
any spaces at the end of the lines in the raw mail.

Comment 10

20 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16
Assignee

Comment 11

19 years ago
Since noone has commented, I'll mark this one WORKSFORME.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.