left frame click target middle frame but then right frame link click results in no action...must refresh frameset page...to repeat over again

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: John Flaherty, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

http://65.36.181.67/ihtml32.aspx works fine in mozilla,
http://65.36.181.67/ihtml40.aspx which uses left and right frames containing URL
link-lists with images that when clicked should target the center frame but do
not do anythiing at all after the initial link is clicked meaning the first time
a link in the left frame is clicked it works and target the middle frame but
after that if a link on the right is clicked  the click results in no action
taken by the browser...perhaps a document.history issue givien a related article
I read  regarding javascript document.location issue with frames also in
Mozilla.  Thanks for all you do.

Reproducible: Always

Steps to Reproduce:
1. Click a link in left frame of http://65.36.181.67/ihtml40.aspx
2. Click a link in right frame of http://65.36.181.67/ihtml40.aspx
3. The first linked clicked works fine and the second linked click will not work.

Actual Results:  
The same exact 1.2.3. steps I have written above happenned after I performed the
steps above.

Expected Results:  
If frame web page A target frame page B, then frame page B is being targeted by
frame web page A, which is just another frame page in a frameset web page, the
targeted frame web page B should display the contents of the framed/non-framed
web page associated with the link that was clicked in frame web page, A.
where
A is the shooter
B is the target.

John Flaherty
3601 College Drive
Louisville, KY, USA 40299-3601
1-502-718-6471
smartwebagent@hotmail.com
http://65.36.181.67
http://yb2d.com
http://yououtfoxedthefox.com
http://smartwebagent.com
http://pocketwebagent.com
http://onlinefactsheet.com
http://onlinefactsheets.com
http://thegamersstation.com
http://trishsegrest.com
http://trishsellshouses.com
http;//derbycityrealestate.com
http://derbycityrealty.com

Comment 1

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

I couldn't see the right hand images as being links at all, but the links
actually worked, even after using the left hand frame.

Could you give a more detailled description of the recipe and perhaps a smaller
testcase?

Comment 2

13 years ago
reporter, please provide clearer description and as small testcase as possible.
Thanks
Summary: LEFT FRAME CLICK TARGET MIDDLE FRAME BUT THEN RIGHT FRAME LINK CLICK RESULTS IN NO ACTION...MUST REFRESH FRAMESET PAGE...TO REPEAT OVER AGAIN → left frame click target middle frame but then right frame link click results in no action...must refresh frameset page...to repeat over again
(Reporter)

Comment 3

13 years ago
Was using pre 1.0 version of Firefox browser version 0.9 when problem occurred.

Have since downloaded 1.0 version of Firefox browser and all HTML 4.0 frames 
features are working correctly.

Thank you all for all of your time.

Respectfully,

John Flaherty
smartwebagent@hotmail.com
http://www.smartwebagent.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

13 years ago
->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.