Unable to type into any Text form fields after loading HTMLArea 3.0 from Interactive Tools. Happens even after the browser is closed, re-opened and still happens after computer is restarted..

RESOLVED EXPIRED

Status

()

Firefox
General
--
major
RESOLVED EXPIRED
13 years ago
13 years ago

People

(Reporter: Teravus Ovares, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

I went to this page above, started typing in the HTML Area Box..    clicked  the
ABC icon(spell check).   Fixed the words that it suggested.   Then, clicked on
the Attach paperclip to the right of the Address Book Button..   clicked Finish.  

Now in FireFox on Mac OSX 10.3.7, I can't type in ANY Text Area boxes on ANY
sites.  I tried Google..  I tried logging into bugzilla.mozilla.org.  I can't
type into text fields now.   The text fields don't even look like the cursor
goes into them.

What is crittical about this bug is that even after FireFox is closed and then
re-opened, No Text forms can clicked or typed into.   Even after a computer
Re-Start, No Text forms can be clicked or typed into.   

Apple Safari, does allow typing into text fields, so it appears to be a FireFox
issue.

This issue does not happen on the Windows Version of FireFox

Seems, eventually..  I can type into text fields again..   after I have browsed
the web a little bit..  

One more wierd issue, is when the browser is stuck like that, I can't even type
into the address bar.  It won't get focus.

Reproducible: Always

Actual Results:  
Unable to Type into text fields on ANY sites including the http://www.Google.com
Search box.  No Text Bar Cursor is displayed in the text boxes when they are
clicked.

Expected Results:  
The software should have displayed a cursor in the text box when I clicked it
and allowed me to type.

Build platform
target
powerpc-apple-darwin7.7.0

Build tools
Compiler 	Version 	Compiler flags
cc 	gcc version 3.3 20030304 (Apple Computer, Inc. build 1640) 	-Wall -W
-Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include -fpascal-strings -no-cpp-precomp
-fno-common -I/Developer/SDKs/MacOSX10.2.8.sdk/Developer/Headers/FlatCarbon -pipe
c++ 	gcc version 3.3 20030304 (Apple Computer, Inc. build 1640) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include -fpascal-strings
-no-cpp-precomp -fno-common -fshort-wchar
-I/Developer/SDKs/MacOSX10.2.8.sdk/Developer/Headers/FlatCarbon -pipe

Configure arguments
--disable-ldap --disable-mailnews
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth
--enable-crypto --disable-composer --enable-single-profile
--disable-profilesharing '--enable-optimize=-O2 -g' --disable-debug
--disable-tests --enable-official-branding --enable-static --disable-shared
--enable-prebinding --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk

One odd configuration that I'm using on my Mac is I'm using Synergy to re-direct
the PC's mouse to the mac, however, I tested the Keyboard and mouse that are
hooked directly into the Mac and had the same erroneous result.
(Reporter)

Comment 1

13 years ago
It appears to have to do with something the spell checker does.  Test the spell
checker..  ( locked it to have one spelling error since the spell checker
functionality is not available on the demo server )


One more Important thing that I found..   was if I switch to another window..  
such as Safari..   and then go back to FireFox, I can type in the text fields
again. 

I noticed another bug similar.   It may be fixed by fixing bug 281610 which
appeared to be an issue surrounding the russian character set.

I'm using En_US.
Severity: critical → major

Comment 2

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

I can't get the HTML Area to work at all.

Perhaps what happened to you after a period of time has already happened to 
me! I will try again.
(Reporter)

Comment 3

13 years ago
hrm..   I'm sure that I can't get HTMLArea 2.x to work in mac FireFox, however I am able to get 
HTMLArea 3.0 RC2 to work.   (grin)  HTMLArea isn't the focus of the bug though..  It is really the fact 
that after using the spell checker,  *NO* text fields work, not even the address bar in firefox.

(In reply to comment #2)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
> Firefox/1.0+
> 
> I can't get the HTML Area to work at all.
> 
> Perhaps what happened to you after a period of time has already happened to 
> me! I will try again.

Comment 4

13 years ago
I don't know if this is related or not, let me know if you want a separate bug
report on it...

Frequently, but intermittently, I'll go to a window that's been idle for a while
and try to enter data in a text field.  It won't let me type anything and I have
go to another window to enter data.  Don't have to close Firefox at all in my
case, just that window is hosed.  I usually just close it and bring up a new
one.  It's frequent enough to be annoying because I run a mini-blog in a wiki at
work to keep track of what I do during the day, and it needs to be fairly
unintrusive.  Having to close the window and navigate back to the blog page is
anything but...
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.