If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 284986 (transparent_gifs)

Bad rendering of gif images with transparency (banding, stripes) when slow scrolling on/off a pane

RESOLVED DUPLICATE of bug 104992

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 104992
13 years ago
13 years ago

People

(Reporter: Jasper Lieber, Unassigned)

Tracking

({helpwanted, qawanted})

1.7 Branch
x86
Windows 98
helpwanted, qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(9 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616

(This started with the long thread at Bugzilla Bug 201198, "White lines appear
on images when scrolling slowly through page".)

A specific type of .gif image does not render correctly when the gif is slow
scrolled on or off the window pane.   There's an example at the URL mentioned
with this bug, and many web site banners can also show the problem, including
www.slashdot.org, and www.mathforum.org.  When such a gif is scrolled on or off
the window pane, banding or ghosting or stripes appear in the gif.  (The window
must be small enough to require scrolling.)  

Reproducible: Always

Steps to Reproduce:
The conditions to show the bug are:

  *  a .gif image with transparency, in a window pane
  *  (i can't demonstrate this bug with .gif's without transparency,
     nor with .jpg, .tif, .png)
  *  the pane containing the gif is scrolled on or off the window
  *  the video mode is 32 or 16 bit (NOT 8 or 24 bit color depth)

Other notes:
  *  The bug is appearing 100% of the time for me now, but in the past I
     thought this bug was intermittent.  I currently believe that with these
     conditions it's always reproducible.
  *  IE and the Avant browser render the gifs correctly.


Actual Results:  
Examples of wrongly rendered images will be attached to this bug.  Again, the
banner in the top of slashdot.org or mathforum.org will show the bug.

Watching carefully, it looks like the transparency rectangle is moved
differently than the rectangle of visible pixels.  The transparency can get
pushed around and then placed incorrectly!

Expected Results:  
The gifs should be rendered correctly, of course!  I.E. and the Avant browser
work, I haven't checked other browsers.  

I'm breaking this bug out of the thread at Bugzilla Bug 201198.  
This bug is also related to Bug 214965 (which also has good examples).

I think and hope that it's justified to break this bug (buglet?) off from the
thread at 201198 - I feel like the conditions for this bug are now so well
described that it warrants being it's own thread.  (I guess it's a "normal" bug,
or maybe it's lower priority.)

Other bugs that may or may not be related are these:
	https://bugzilla.mozilla.org/show_bug.cgi?id=36002	
	https://bugzilla.mozilla.org/show_bug.cgi?id=284756	   
             http://www.geocities.com/ociretsih/Bugzilla/Diario.html
	https://bugzilla.mozilla.org/show_bug.cgi?id=141656	
             Although this one is about printing, there might be a link here.    
             Plus there are many links to other bugs, for further research.
	https://bugzilla.mozilla.org/show_bug.cgi?id=214965	
	https://bugzilla.mozilla.org/show_bug.cgi?id=265610	
	https://bugzilla.mozilla.org/show_bug.cgi?id=214829	
	https://bugzilla.mozilla.org/show_bug.cg?id=137733	
	https://bugzilla.mozilla.org/show_bug.cgi?id=156653	
            excellent example 
	https://bugzilla.mozilla.org/show_bug.cgi?id=279242
(Reporter)

Updated

13 years ago
Alias: transparent_gifs
Blocks: 201198, 214965
(Reporter)

Comment 1

13 years ago
Created attachment 176448 [details]
example of bad rendering of a gif with transparency after scrolling
(Reporter)

Comment 2

13 years ago
Created attachment 176449 [details]
the about:buildconfig output from my mozilla
(Reporter)

Comment 3

13 years ago
Created attachment 176450 [details]
Example of a gif that renders incorrectly when scrolled through (from bug 214965).

taken from Bug 214965
(Reporter)

Comment 4

13 years ago
Created attachment 176452 [details]
What the ~jhb7001 site looks like to me...
(Reporter)

Comment 5

13 years ago
A bit more history:  I was able to trace this bug by tearing the bad gif out of
mathforum.org and making the simple webpage using MS FrontPage (ick).  In
frontpage, you can set two flags for .gif images:  interlaced and transparent. 
The problem is with the gifs with the transparent flag set.

A comment in some other bug prompted me to find out that the bug only happens in
the 16 and 32 bit color depths.

This is not just a video adapter driver problem since the gifs render correctly
in IE and Avant.

That's all I have for now.  By the way, I'm looking for work, I'm a good C++
programmer....you can see my resume at goatwalker.com

Comment 6

13 years ago
Created attachment 176457 [details]
wfm, screenshot jhb 7001 win98

Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050305

Works for me using a current trunk nightly, win98, 800x600, Sis6326
graficscard.
You are using a nearly nine months old Mozilla 1.7, please upgrade to 1.7.5 or
1.8b1 and retest.
(Reporter)

Comment 7

13 years ago
Created attachment 176464 [details]
my updated mozilla 1.7.5 builconfig output

I can still reproduce the bug after updating...

I updated my mozilla to the latest from mozilla.org, 1.7.5
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041217
(Reporter)

Comment 8

13 years ago
(In reply to comment #6)
> Works for me using a current trunk nightly, win98, 800x600, Sis6326
> graficscard.
> You are using a nearly nine months old Mozilla 1.7, please upgrade to 1.7.5 or
> 1.8b1 and retest.

I updated (see previous comment) but still can reproduce.

Just checking:  is it clear that scrolling is necessary to demonstrate the bug?
 In order to see the bug, the .gif image needs to be scrolled in and out of the
visible part of the window pane.  Herman, when you went to ~jhb7001, did you
scroll the gifs off the screen?

Comment 9

13 years ago
(In reply to comment #8)
> (In reply to comment #6)

> I updated (see previous comment) but still can reproduce.
> 
> Just checking:  is it clear that scrolling is necessary to demonstrate the bug?
>  In order to see the bug, the .gif image needs to be scrolled in and out of the
> visible part of the window pane.  Herman, when you went to ~jhb7001, did you
> scroll the gifs off the screen?
> 

I checked ~jhb7001 scrolling horizontally and vertically, slow, fast, and all
was well, and retested:

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050305

Maybe you should tell us about screen resolution, grafics card, and drivers.
There are bugs about problems with some graficcards and older drivers.

Version: unspecified → 1.7 Branch
(Reporter)

Comment 10

13 years ago
Created attachment 176471 [details]
a screenshot of my display settings and adapter driver version

Here's a screenshot of my display settings and video adapter driver info.  I'm
running an old dell inspiron 7000 with a celeron 366 and 196MB of mem.	I've
got a Rage Mobility-P AGP graphics driver from ATI Tech, Software version
M6.00.4-T01.  I've tested at all screen resolutions, in 32-bit color depth, I
get the bug.  


Reminder that the bug only appears in mozilla, not IE or Avant.



Microsoft Windows 98 4.10.2222 A 
Upgrade using Full OEM CD /T:C:\WININST0.400 /SrcDir=E:\WIN98 /IZ /IS /IQ /IT
/II /NR /II /C	/U:xxxxxxxxxxxxxxxxx
IE 5 6.0.2800.1106
Uptime: 0:00:19:43
Normal mode
On "CHARLIE" as "Default"
Dell Computer Corporation
GenuineIntel Intel(r) Celeron(tm) Processor 
192MB RAM
75% system resources free
Windows-managed swap file on drive C (1269MB free)
Available space on drive C: 1269MB of 6182MB (FAT32)
(Reporter)

Comment 11

13 years ago
Bug 284986
I stumbled across Bug 64401 "Extremely slow performance with png background",
which just demonstrates that there are other file formats (png) that are broken.
 At that bug, I posted how a png file scrolled incorrectly.  Cheers.
(Reporter)

Comment 12

13 years ago
(In reply to comment #11)
> Bug 284986
> I stumbled across Bug 64401 "Extremely slow performance with png background",
> which just demonstrates that there are other file formats (png) that are broken.
>  At that bug, I posted how a png file scrolled incorrectly.  Cheers.

FYI:  Looks like this png bug is unrelated to the gif bug...  don't want to
muddy the waters, so I thought I'd mention this.
(Reporter)

Comment 13

13 years ago
Created attachment 176559 [details]
Example of bad banner at www.slashdot.org

The attachment shows the bug with the banner at www.slashdot.org 

So can anyone confirm this?  I've just tested with the latest nightly build
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050306

Seems to me that a bug that makes a mess of the banner of slashdot.org and is
easily reproducible is a pretty good bug!  But is it only me seeing it?
(Reporter)

Comment 14

13 years ago
Created attachment 176564 [details]
Best example yet of how the transparency layer gets pushed around

And here's the best example I've seen yet (from bug 265610)

Go to http://www.geneesmiddelenrepertorium.nl/125_corso_09822.html

Change the size of the window - when it's shorter than than the logo, what I
see is the transparent layer of the logo get's pushed around differently than
the non-transparent part.
(Reporter)

Comment 15

13 years ago
(In reply to comment #14)
> http://www.geneesmiddelenrepertorium.nl/125_corso_09822.html
> http://www.slashdot.org

I cannot reproduce this on my friends XP machine
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
So the first question is, can you reproduce the problem with a current trunk build?
(Reporter)

Comment 17

13 years ago
(In reply to comment #16)
> So the first question is, can you reproduce the problem with a current trunk
build?

Yes.  I have now tested on 1.7.5, the nightly from a couple nights ago, and most
lately with 1.8b (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b) Gecko/20050217).  

Here's what I'm currently seeing (for both Firefox and Mozilla)
* fresh start of the application, transparent gifs not working
* i start up something in java (www.java.com) (and can even close java)
* transparent gifs are now rendering properly (bug gone)
* restart the firefox or moz, and the bug reappears
* (and if both Firefox and Moz are running, and one of them has invoked java, 
  then the bug is gone in both apps and stays gone until both apps are closed)
(Reporter)

Comment 18

13 years ago
It's so quiet out there - can anyone else reproduce this bug?  Or am I all alone
in the universe?
I can't on Linux... it may be OS-dependent, and likely dependent on the grapics
card.... :(
Keywords: helpwanted, qawanted

Updated

13 years ago
No longer blocks: 201198
(Reporter)

Comment 20

13 years ago
It looks this bug is a dupe of Bug 104992.

I've updated my ATI display drivers, and the bug appears to be gone.

*** This bug has been marked as a duplicate of 104992 ***
No longer blocks: 214965
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 21

13 years ago
Turns out my rendering problems were related to my old ATI graphics card, and
the problem was well described (and solved) by the notes at Bug 104992.  If
anyone else has the problems described by me this bug, check out the notes at
Bug 104992.  Cheers!
Depends on: 104992
You need to log in before you can comment on or make changes to this bug.