All users were logged out of Bugzilla on October 13th, 2018

decebalcomputing.xs4all.nl - application/xhtml+xml without a declared namespace

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: Cecil, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

In Konqueror and on my GSM there is no problem with the page:
    http://decebalcomputing.xs4all.nl/cgi-bin/WAP.cgi
Also validator.w3.org says this page is okay.
But with FireFox in Linux and Windows and Windows I get:
     This XML file does not appear to have any style information associated with
it. The document tree is shown below.
(As I understand it MIE has the same problem.)
When in the header content-type is changed to text/html everything is okay, but
because it is a wap-application it should be application/xhtml+xml as it is now.

Reproducible: Always

Steps to Reproduce:
1. Open http://decebalcomputing.xs4all.nl/cgi-bin/WAP.cgi

Actual Results:  
Instead of the page a document tree is shown.

Expected Results:  
Displaying a page.
This is a duplicate of bug 48445. 
The page have to specify the xhtml namespace, like <html
xmlns="http://www.w3.org/1999/xhtml">.
Not exactly a dup of bug 48445, since if you fix the typoed URI in your doctype
(which currently refers to an xhml DTD, rather than xhtml), the doctype doesn't
attempt to set a FIXED namespace attribute (which we would ignore), but instead
instructs you that you must have a namespace declaration on the root element.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
I do not think this is a duplicate from bug 48445. There the problem is when you
use text/html as content-type. In this case the problem is 'solved' when using
text/html as content-type. But instead of using text/html I want to use
application/xhtml+xml.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
No, it's not a duplicate, it's invalid. If you want to use XHTML as XML, then
you have to declare the XHTML namespace on your root element. That's what I
said, that's what your DTD says you have to do, in a comment, once you fix the
URL in the doctype declaration so you are actually referring to the DTD you intend.

<html xmlns="http://www.w3.org/1999/xhtml">
Assignee: firefox → english-other
Component: General → English Other
Product: Firefox → Tech Evangelism
QA Contact: general → english-other
Summary: Firefox does not handle content-type application/xhtml+xml correctly → decebalcomputing.xs4all.nl - application/xhtml+xml without a declared namespace
(Reporter)

Comment 5

14 years ago
Okay, that solves it. The information from Nokia was wrong then. (I made the
document on there specifications. I only started programming for wap last week.)
Strange that validator.w3.org did not complain.

There is one little difference with content-type text/html. With text/html the
complete document is purple, with application/xhml+xml only the part with text
is purple. Is this correct?
I still say it's a dupe. See bug 221624 that was indeed duped against bug 48445
(invalid).

> with application/xhml+xml only the part with text is purple.

There are some differences with how css is applied in xhtml vs html. E.g.
setting background of the body element vs the html element. Might have to do
with that. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.