text-align: justify screws up hebrew rendering

RESOLVED DUPLICATE of bug 284927

Status

()

defect
RESOLVED DUPLICATE of bug 284927
14 years ago
5 years ago

People

(Reporter: spotter, Assigned: mkaply)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Win; U; Linux i686; en-US; rv:1.7.5) Gecko/20050221 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0+dfsg.1-6ubuntu1)
Build Identifier: Mozilla/5.0 (Win; U; Linux i686; en-US; rv:1.7.5) Gecko/20050221 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0+dfsg.1-6ubuntu1)

In the page http://www.mechon-mamre.org/i/t/t0201.htm they use the text-align
justify attribute for a lot of their text, but it screws up hebrew rending very
badly.

For combining characters it totally screws it up, while for non combining
characters it just reverses the order (i.e. what should be displayed ABC comes
out BCA)

if you remove the justify attribute it displays very well (albiet not fully
justified)

Reproducible: Always

Steps to Reproduce:
1. go to the http://www.mechon-mamre.org/i/t/t0201.htm
2. look at the page, it should be very messed up as described
3. save the page and the css file, edit the cs file to remove the justify attribute
4) view the file w/ modified css and it should look fine.

Updated

14 years ago
Assignee: firefox → mkaply
Component: General → Layout: BiDi Hebrew & Arabic
Product: Firefox → Core
QA Contact: general → zach
Version: unspecified → Trunk
(Reporter)

Comment 1

14 years ago
while it works fine in firefox (1.0 and 1.0.1) without the justify attribute, it
doesn't seem to work with mozilla suite 1.7.5
Is this really a problem on all OSes?  Or just Linux?

If the latter, does setting the MOZ_DISABLE_PANGO env var to 1 before running
Firefox/Mozilla change the behavior here?
(Reporter)

Comment 3

14 years ago
yes.  I can reproduce it mostly on windows.

On windows I don't have the "reverse" problem, but I do have the screwed up UTF8
combining characters (when justify is used, when removed it displays fine.

basically win/linux have issue w/ combining characters (i.e. hebrew letters w/
nikkud) and justify attribute

win mozilla (1.7.5)/firefox (1.0.1) and Linux mozilla (1.7.5) don't reverse the
order of non combining characters (plain hebrew)

Linux firefox (1.0 ubuntu package) does reverse the order of non combining
characters (plain hebrew)

export MOZ_DISABLE_PANGO=1 ; mozilla-firefox doesn't change anything.
(Reporter)

Comment 4

14 years ago
as one can see the text is justified, but the combining characters aren't
active.
(Reporter)

Comment 5

14 years ago
as one can see, the text is no longer justified, and combing characters are
still not combined.
(Reporter)

Comment 6

14 years ago
As one can see the text is justified, but rendered oh so horribly.
(Reporter)

Comment 7

14 years ago
As one can see the text is no longered justified, but rendered very well.
(Reporter)

Comment 8

14 years ago
source file for the above images.
(Reporter)

Comment 9

14 years ago
css file for the source file with justification off
(Reporter)

Comment 10

14 years ago
css file w/ justification on.
Whiteboard: DUPEME
email from the reporter:

>Well I now know more details.  It seems when used with pagno, justify
>screws everything up.  without pango, combining characters dont work (a
>different problem)

The pango issue is a dupe of bug 284927. Combining characters without pango is a
dupe of bug 60546.

*** This bug has been marked as a duplicate of 284927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.