Extension Writers Must Be Notified to Upgrade Extensions for Firefox v.1.0.1 Compatability vs 1.0

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: Richard Nielson, Unassigned)

Tracking

unspecified
x86
All

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Firefox/1.0.1 v Firefox 1.0

The Extensions for the Firefox Upgrade ( V.1.0.1 ) have not been upgraded from
version 1.0 compatability.
The Extension Program Writers Should have been notified before the New Version
was released so that they may have had the time necessary to Write Upgrade Code.
Almost all the Extensions are for Version .0.9 to 1.0..

Reproducible: Always

Steps to Reproduce:
1.Plug in v.1.0.1 into the Bar with the OS selection Bubbles Select v.1.0.1 and
Hit the Update Button
2.
3.

Actual Results:  
all the extensions defaulted to v.0.9/v.1.0.

Expected Results:  
Been Upgraded Prior to the New Version Release as addressed in DETAILS above.

no crash just a lack of anticipating the need for the Extension Upgrades.

Comment 1

13 years ago
1) There is no impact to extensions for this subversion release.  All 1.0
extensions should work for 1.0.1.
2) There was notification via the usual Mozilla blogs that 1.0.1 was going to be
released. 
3) The real impact will be for a release such as 1.1, but developers should be
aware that it is coming and testing is needed.  Extensions that work with 1.1
will need to be submitted for testing in advance.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.