Ja chars in the mail header of forwarded (as attachment) mail are displayed as dots in the mail body.

VERIFIED FIXED in M15

Status

defect
P3
normal
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: ji, Assigned: rhp)

Tracking

Trunk
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

()

Build: 2000021808

When forwarding a mail as an attachment, if the mail has Japanese sender and
recipient name, those Ja names are displayed as dots when received.

Steps of reproduce:
1. Have a mail in your mail box with sender and recipient's name containing
   Japanese characters.
2. Forward the mail to the testing account itself as an attachment.
   Select View | Character Set | Japanese (ISO-2022-JP) before sending it out.
3. Open the mail after received.

You'll see on the message view pane, the Japanese sender and recipient name
are displayed as dots in the mail body.

It doesn't occur with M13.
Ja subject are displayed as dots too. 

Easier way to reproduce:
1. Unzip the smoketest folder shown in the above URL. 
2. Put it in your testing mail directory.
3. select the 3rd mail in the smoketest mail folder 
4. Forward it to your testing account as an attachment.
Summary: Ja sender and recipient's names of forwarded (as attachment) mail are displayed as dots in the mail body. → Ja chars in the mail header of forwarded (as attachment) mail are displayed as dots in the mail body.
Forward attachment problem, reassign to rhp.
Assignee: nhotta → rhp
Just something I have to dig into.

- rhp
Status: NEW → ASSIGNED
Target Milestone: M15
Good catch. This is fixed as part of my SaveAs fix that I am going to get
approved and checked in this weekend.

- rhp
Over to ji as QA contact.
QA Contact: momoi → ji
All better now.

- rhp
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Verified/fixed with 2000022212 linux build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.