Closed Bug 28508 Opened 25 years ago Closed 24 years ago

linux,win: Select All doesn't work from context menus

Categories

(Core :: XUL, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bugzilla, Assigned: saari)

References

Details

(Keywords: platform-parity, regression, Whiteboard: [PDT-][nsbeta3+])

found this while trying verify bug 24685; using opt comm bits 2000021808. only
occurs on linux and winNT; not a problem on mac.

bring up a context menu (a page with or without frames) and select Select All.
result: nothing is selected.
this is a regression...also nominating for beta1.
Blocks: 24685
Severity: normal → major
Keywords: beta1, pp, regression
um, i don't see why this would be an xpmenu bug, though i could easily be proven 
incorrect. reassigning to don.
Assignee: pinkerton → don
pink: it works on Mac, but not Windows or Linux (yet the code is entirely XP). So 
there is some weirdness which causes a difference between platforms. So I think 
someone in your group should take a look.
Assignee: don → pinkerton
saari? um? what is up here? smells like focus.
Assignee: pinkerton → saari
I looked at this, and I can't tell that focus is what is wrong, and here is why: 
the commands update properly, despite nothing drawing. 

I'll look again.
Status: NEW → ASSIGNED
Target Milestone: M14
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]
move to M15
Target Milestone: M14 → M15
Mass-moving most M15 bugs to M16
Target Milestone: M15 → M16
I can make this break even when not using the context menus. I still think this 
is an ender or painting update bug.
I'm not so sure: i think there are some bugs with the way that context menus are 
handled. Try the Copy context menu item for example; this works fine on Mac, but 
not on Linux or Windows. Select All also behaves differently. Both these commands 
use command nodes and go through the controller (unlike the other context menu 
items).
moving to m18, since this feature is new, seldom used, and most users will bonk 
Ctrl-A
Target Milestone: M16 → M18
pardon the spam: beta1 is long gone...removing this keyword. will soon replace
w/nsbeta2...
Keywords: beta1
mass-moving all '-' bugs to M20
Target Milestone: M18 → M20
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
The platform specific nature of this bug worries me, so I'd like to look at it 
for beta3. Plus it looks pretty bad when menu items just don't work.
Keywords: nsbeta3
nsbeta3+ Those bonking Ctrl-A will think this feature is missing, since it 
mysteriously switches modifiers to Alt.
Whiteboard: [PDT-] → [PDT-][nsbeta3+]
Target Milestone: M20 → M18
What's (somewhat) weird is that if you right-click to show the context menu, 
then press 'l' (the access key for Select All), the text *will* be selected.  
This means that it's not a problem with the menuitem itself, but rather only a 
problem with _clicking_ the menu item.  This makes me think that perhaps 
something isn't happening to the click that should be (maybe it's bubbling too 
far and not getting destroyed?)
cc:sujay
*** Bug 45775 has been marked as a duplicate of this bug. ***
This seems to be working in recent builds (on windows)...
Fixed
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
verified fixed -- using the context menu [as well as ctrl/cmd-A, typing l into 
the context menu (win/linux), and from the main menu] selects all the content
-- mac/linux/win32 20000828nn builds. Also works in message pane of mailnews 
(the dup of this bug ).
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.