If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

One-form of AddDirectory() is not supported. Install aborts w/ -208 error

VERIFIED FIXED in M14

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: David Epstein, Assigned: dougt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]fix in hand.)

(Reporter)

Description

18 years ago
1. Go to http://jimbob/trigger2.html
2. Select a_addDirectory_1 from drop down or type in URL. archive contains 
zipped up folder. script uses SetPackageFolder() after getFolder().
3. Trigger.
4. OK at confirm dlog.
Results: No installation of folder. Logfile:

 addFileNoVers1
     --------------

     ** the error = -208

     Install script aborted
     Finished Installation  02/18/2000 16:42:48


http://lxr.mozilla.org/seamonkey/source/xpinstall/src/nsInstall.cpp#454

Comment 1

18 years ago
*** Bug 28513 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Reassigning QA Contact to David.
QA Contact: jimmylee → depstein

Comment 3

18 years ago
assign to dougt.
putting on beta1 radar.
Assignee: cathleen → dougt
Keywords: beta1
Target Milestone: M14
(Assignee)

Comment 4

18 years ago
-------------------------------------------------------------------------------
http://jimbob/jars/a_adddirectory_1.xpi  --  02/21/2000 22:21:16
-------------------------------------------------------------------------------

     addFileNoVers1
     --------------

     ** the error = 0
     [1/1]	Installing: D:\cmonkey\mozilla\dist\WIN32_D.OBJ\bin\smrtupdt.txt

     Install completed successfully
     Finished Installation  02/21/2000 22:21:36
Status: NEW → ASSIGNED
Whiteboard: fix in hand.

Comment 5

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: fix in hand. → [PDT+]fix in hand.

Comment 6

18 years ago
Doug, can you check that fix in?  a=cathleen  :-)
(Assignee)

Comment 7

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
It's now supported, but it doesn't create the jar source directory (adddir1). It 
directly installs the file(s) inside of this source directory (smrtupdt.txt). 
I'll verify this one, investigate the prob further, then submit another bug if 
necessary.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.