If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

use of img tag in table leaves space at bottom between img and table border

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: ccrowder, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

When using a <img> tag inside a table cell there is a small band of empty space
that is inserted into the table cell below the image.  This is seen even when
you manually set both the table/row/cell size along with the image size.  In the
posted link you can easily see this since I have set the cell background to a
color.  http://abserver2.mmg.uci.edu/~ccrowder/lab/bartest2.html

Reproducible: Always

Steps to Reproduce:
1.  Just load the page
2.
3.



Expected Results:  
If you load the above page in IE or safari it correctly sizes the table to fit
the image so that 2 rows will have no vertical space between the two images.

Comment 1

13 years ago
This happens because the image sits on the baseline of the inline box. See
http://web.archive.org/web/20031203014410/http://devedge.netscape.com/viewsource/2002/img-table/
for a explanation and some solutions (note that the images seems to be gone).

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.