Windows will crash with BSOD error 0x0000001e when Encryption vs Obscuring is on

RESOLVED INVALID

Status

NSS
Libraries
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Jorden van der Elst, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050303
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050303

When I enable Encryption vs Obscuring under Preferences, Security & Privacy,
Passwords and go to my email, I get the special password window. 
Filling in my password leads directly to the Blue Screen of Death with error
0x0000001E

Strange as it seems, as I even tried it with no media in any of my optical
drives, as this error is usually a failing ASPI32 layer problem. My ASPI layers
are at the latest available from Adaptec, v.4.71_2


Reproducible: Always

Steps to Reproduce:




I was just testing the encryption vs Obscurity, so for me it isn't a really
broken issue. I can work around it by disabling the feature again.

Comment 1

14 years ago
i don't suppose i can interest you in the kernel debugger from microsoft?
there's very little we're going to do with this w/o a stack (and even then, it's
a driver fault, but at least windbg would tell you about it).
Assignee: sspitzer → wtchang
Component: MailNews: Main Mail Window → Libraries
Product: Mozilla Application Suite → NSS
QA Contact: bishakhabanerjee
(Reporter)

Comment 2

14 years ago
If only windbg could find a minidump file, which it can't. I have my minidumps,
or any dumps disabled. So I go to a BSOD straight away. 

The BSOD does not point to ASPI32 nor to any other file. If I had a digital
camera, I'd show you my BSOD, but I haven't got one, so that's moot. 
Event Viewer in Windows shows absolutely nothing at the time of the BSODs. It
just records the reboot/winlogon.

I only pointed to ASPI32 and my drives, so we could exclude those. 

Updated

14 years ago
Summary: Windows will crash with BSOD error 0x0000001e when Encyption vs Obscuring is on → Windows will crash with BSOD error 0x0000001e when Encryption vs Obscuring is on
Timeless, I see no evidence this is an NSS problem, as opposed to a PSM 
problem, or something else entirely.

Comment 4

14 years ago
nelson@bolyard.com: it's an invalid bug, but given that nss is a lower layer,
i'd rather leave the bug closer to it for the time being.

reporter: could you enable detailed dumps and reproduce?
(Reporter)

Comment 5

14 years ago
I'll try tomorrow. Once the wife stops downloading. ;)
(Reporter)

Comment 6

14 years ago
Okay, I put Autoreboot on, dump debug file on, went over to the Obscuring vs
Encryption and checked it. Quit Mozilla, loaded it again, went to my mail,
filled in the password and this time it worked. (grmbl)

But then I went on to uninstall Mozilla, while the OvsE was still on, because I
had downloaded the latest nightly and installed that. The next half an hour I've
gone through various reboots, uninstalls, reinstalls and more, because all of my
Mozilla installations came out looking like this:

http://img.photobucket.com/albums/v289/Ageless/Mozilla/broken-arrow.png

I managed to fix that, by finally deleting my profile (after backing it up, of
course), then reinstalling the Mozilla I had been using, disabling OvsE,
uninstalling Mozilla whole again and installing the latest nightly. 

I am really wondering if is all related or not. 

Btw, I checked Dr. Watson and even that one had no recollection of me BSOD'ing
to the error 0x1e. I guess I'll have to test this again, creating the same
situation as I was under when it first happened. 

I'll let you know. 
QA Contact: bishakhabanerjee → jason.m.reid
A BSOD can only be caused by a bug in Windows Operating System.
Therefore, this bug cannot be an NSS bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.