refresh/reload of web site does not chnage graphics or downloaded files

RESOLVED DUPLICATE of bug 80922

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 80922
14 years ago
5 years ago

People

(Reporter: bill.moz, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

I have a personal web page that I use when loggin onto the web. One picture on
the web is from
http://radblast.wunderground.com/cgi-bin/radar/WUNIDS?station=HGX19 and when I
log in I need to refresh the page to get the latest picture. This Sunday 3/6 I
uploaded a movie file to the pickmovie.htm link listed in the URL and when I
attempted to view it the file that was displayed and played was the old one. I
stopped Firefox and at one point logged out and back on and still could not view
the new file. One I cleared the cache I finally was able to download and view
the new file.

Reproducible: Always

Steps to Reproduce:
1. View mpg file
2. upload new file
3. attempt download of new file

Actual Results:  
The old file is viewed.

Expected Results:  
The new file should be viewed.

Comment 1

14 years ago
This does not sound like anything Firefox specific.  Over to core product...

Were you just clicking a regular link to download the file?
Assignee: bugs → file-handling
Component: Download Manager → File Handling
Product: Firefox → Core
QA Contact: aebrahim-bmo → ian
Version: unspecified → 1.7 Branch

Comment 2

14 years ago
Check your cache settings. Also: To force a reload, use ctrl+reload

Comment 3

14 years ago
(In reply to comment #2)
> Check your cache settings. Also: To force a reload, use ctrl+reload

correction, make that: shift+reload
(Reporter)

Comment 4

14 years ago
Yes, when I download the file, typically called Movie1.mpg, I click on the
following link http://home.houston.rr.com/billhopp/Movie1.mpg to see the movie
file. On Sunday I uploaded a new file and clicked on the link and the player
displayed last week's file. I refreshed, tried logging out and back in and
finally wnet to the tools area and cleared the cache to get the new file to be
displayed.
This has come up in the past -- some people argue that "save link as" should
always bypass cache.  I don't think there was agreement on the issue, though...
 In any case, that's a Firefox UI issue, not a core one; the relevant code is UI
code.
Assignee: file-handling → bugs
Component: File Handling → File Handling
Product: Core → Firefox
QA Contact: ian → aebrahim-bmo
Whiteboard: DUPEME
Version: 1.7 Branch → 1.0 Branch

Comment 6

14 years ago
I don't know if this is related, nor what is being used to serve the Guestmap
feature at Bravenet, but when a visitor posts a pin on the map (a gif) it
disappears after autoreload:
http://pub15.bravenet.com/guestmap/show.php?usernum=1241775608
This is now a read-only example, sorry, but a tester could be created for free.
I am using Win98SE, and have submitted feedback to Bravenet.

Comment 7

13 years ago
Seems to be a dupe of bug 80922.

*** This bug has been marked as a duplicate of 80922 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.