A couple of common javascript errors and the way to correct them

RESOLVED INVALID

Status

Tech Evangelism Graveyard
Spanish
RESOLVED INVALID
14 years ago
3 years ago

People

(Reporter: Miguel Quiros, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.3) Gecko/20040922
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.3) Gecko/20040922

Hello. I think that complaining to a site about pages with bad javascript that
only works with Explorer is OK but I think it would be better if we also
indicate them the way to correct the errors.

I have not any knowledge of programming in javascript but looking to the error
messages in the javascript console and to the source code of pages when I find
that something does not work, I see that there are a couple of mistakes that
appear almost everywhere.

The errors I am referring to are those that appear in the javascript console as:
....getElementById... has no properties.
........ is not a function.

I describe this in the site:
http://www.ugr.es/local/mquiros/Javascript_solo_para_Explorer.html
(it is in Spanish but I can provide an English translation if it is thought to
be useful).

Probably, there are already sites that deal with this kind of information but I
have not been able to find them.

Well, I indicate this just hoping that it might be useful, perhaps as a
reference when writting a complaint to a non-working site. I am grateful for any
addition, correction, criticism, etc. If something of this kind already exists
somewhere, sorry for repeating it.


Reproducible: Always
Hi Miguel,

Good text, I bookmark it ;)

If you are interested in participating to a project to improve web standards
compliance in among Spanish sites, send me an email. I am working with Spanish
guys now on such a project, any help is welcome, especially from people with
good writing skills ;)

Pascal

(marking the bug as "invalid", it's not strictly a bug ;) )
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
You are right. This is not a bug at all. I just wanted to make my suggestions
known to people that might make use of them and thought in this way in doing so.

I am writting you an email about the project you are talking about.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.