[FLOAT] incremental reflow bug: text doesn't clear float

VERIFIED WORKSFORME

Status

()

Core
Layout
P2
minor
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: buster)

Tracking

({top100})

Trunk
x86
Linux
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-], URL)

Attachments

(2 attachments)

DESCRIPTION:  In incremental reflow of the page http://www.bn.com/ , text does
not clear the right floating blurb as it should.  (I assume it's a float - I
haven't looked at the source.)

STEPS TO REPRODUCE:
 * load http://www.bn.com/ (must be the first time during the session)

ACTUAL RESULTS:
 * the second section in the body of the page does not clear the float to its
right

EXPECTED RESULTS:
 * correct reflow the first time

DOES NOT WORK CORRECTLY ON:
 * Linux, mozilla, 2000-02-18-08-M14
Created attachment 5469 [details]
screenshot of incorrect behavior
Created attachment 5471 [details]
screenshot of correct behavior (after resize reflow)
Note that in addition to not clearing the float, the text does not flow around
the float, which it should if it doesn't clear.
Keywords: top100

Comment 4

19 years ago
Floater issue. Reassigning to Kipp's bug list
Assignee: troy → kipp
(Assignee)

Comment 5

19 years ago
we'll be attacking floater issues in M16
Summary: incremental reflow bug: text doesn't clear float → [float] incremental reflow bug: text doesn't clear float
Target Milestone: M16
(Assignee)

Comment 6

19 years ago
kipp is very unlikely to fix these, since he's not working ont he project any 
longer.  so I'll take a look.
Assignee: kipp → buster
(Assignee)

Updated

18 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
(Assignee)

Comment 7

18 years ago
mass-moving all remaining M16 bugs to M17
Status: ASSIGNED → NEW
Target Milestone: M16 → M17
Nom. nsbeta3. html4 layout correctness. Recc. nsbeta3+. 
Keywords: nsbeta3
Summary: [float] incremental reflow bug: text doesn't clear float → [FLOAT] incremental reflow bug: text doesn't clear float
correctness of layout on major consumer site. web content backward compat. PDT
please approve.
Keywords: correctness

Comment 10

18 years ago
Denying approval for beta3: too many bugs and not enough resources, so this one 
will have to be atteneded to in the future.
Whiteboard: [nsbeta3-]
The page has changed and we have no copy of the original source, so cannot fix.
Resolving as INVALID but it isn't really, it's "NOTESTCASE"...
Severity: major → minor
Status: NEW → RESOLVED
Last Resolved: 18 years ago
QA Contact: petersen → dbaron
Resolution: --- → WORKSFORME
bah, INVALID, WORKSFORME, what's the difference between friends. :-/

Comment 13

18 years ago
Works for me:
Platform: PC
OS: Redhat 6.2 Linux 2.2.14
Mozilla Build: 2000103108 M18 Trunk Build

Marking as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.